summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/signal-desktop-bin/Manifest3
-rw-r--r--net-im/signal-desktop-bin/metadata.xml13
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-1.0.38.ebuild49
3 files changed, 65 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
new file mode 100644
index 000000000000..9ea4c87aa4be
--- /dev/null
+++ b/net-im/signal-desktop-bin/Manifest
@@ -0,0 +1,3 @@
+DIST signal-desktop_1.0.38_amd64.deb 94694718 SHA256 ea2e215876357e027fbbcb82a57512185cf6fc7f8781819d1e8a8680078389c0 SHA512 a9b01dd4b991e2208613e5b0a70d615a06e9aa95202a15958cb6765612218022b807a8907e49bef6c2c9b7b865250f2682cbc675520364f251a9ed32cd937fb5 WHIRLPOOL 00bb2db589af68d3e706b01ebe5577bb77e20bd425731f6e8a532bc5acb0f7187cebd81bdeb278472685fba4e18c63b011f9f50f353fd518ebde5f81bac5f47d
+EBUILD signal-desktop-bin-1.0.38.ebuild 929 SHA256 8da4749c18cf4f5fd8fe1d2914e5f37434586e07cddf1d75a042b6fb9aac0fee SHA512 6df873c566704bb7c2750d0025699202d4e76277094ca31d40c7ac5bcce00df068d803aabe9d62e0092d76fa4263e6921e9f8f1001a620d1c9988f3d84ec25d8 WHIRLPOOL 624b4016a42d915162f9888d792521e50289da72c61901a9ba9bbb12e0d7057ebf3fee30278839ca91dbe3c03e098bef5f599c4abd531e5a80162ae71efc050a
+MISC metadata.xml 510 SHA256 fdc56e0ae1aaebee1f7f0a4e77bfe3c407ee0f897663530689f28795904fac3e SHA512 9d9ae0f5f1961fc1ad9b0e59f8d2003fc746f6f25dabb6c35b6ee8e151caf25e724b321e0c11a1b02f5431a204215caf5a4614232508b8492a0d33cd4bb46b8a WHIRLPOOL a61ab86ae985c71fb930cf43dfe130c691dbddcf961f99727e78c6ab531e513b59ab7e02e5687f422c14d8552084255aa4dccb63c676e301d90408c2dd6a5633
diff --git a/net-im/signal-desktop-bin/metadata.xml b/net-im/signal-desktop-bin/metadata.xml
new file mode 100644
index 000000000000..0961ae0091e8
--- /dev/null
+++ b/net-im/signal-desktop-bin/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo.bugzilla.2012@r123.de</email>
+ <name>Robert Siebeck</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Signal is an encrypted messenger. It requires an account created through their Android or iOS app.</longdescription>
+</pkgmetadata>
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-1.0.38.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-1.0.38.ebuild
new file mode 100644
index 000000000000..8a6f4926cd85
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-1.0.38.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+
+inherit gnome2-utils unpacker xdg-utils
+
+DESCRIPTION="Signal Desktop"
+HOMEPAGE="https://signal.org/ https://github.com/WhisperSystems/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/main/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ gnome-base/gconf:2
+ dev-libs/libappindicator:3
+ dev-libs/nss
+ x11-libs/libXtst
+ "
+
+QA_PREBUILT="opt/Signal/signal-desktop
+ opt/Signal/libnode.so
+ opt/Signal/libffmpeg.so"
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+ fperms +x /opt/Signal/signal-desktop
+
+ dosym ../../opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}