summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telegram-desktop/files')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.8.3-fix-clang.patch52
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.8.4-remove-private-qt.patch50
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.8.4-system-cppgir.patch50
3 files changed, 0 insertions, 152 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-4.8.3-fix-clang.patch b/net-im/telegram-desktop/files/tdesktop-4.8.3-fix-clang.patch
deleted file mode 100644
index 5135c3c5ef4b..000000000000
--- a/net-im/telegram-desktop/files/tdesktop-4.8.3-fix-clang.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Fix build issues with clang
-
-/var/tmp/portage/net-im/telegram-desktop-4.8.3/work/tdesktop-4.8.3-full/Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp:198:4: error: reference to 'GObject' is ambiguous
- GObject::Object,
- ^
-/usr/include/glib-2.0/gobject/gobject.h:192:42: note: candidate found by name lookup is 'GObject'
-typedef struct _GObject GObject;
- ^
-/var/tmp/portage/net-im/telegram-desktop-4.8.3/work/tdesktop-4.8.3-full_build/gen/gobject/_functions_impl.hpp:10:11: note: candidate found by name lookup is 'gi::repository::GObject'
-namespace GObject {
- ^
---- tdesktop-4.8.3-full.orig/Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp
-+++ tdesktop-4.8.3-full/Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp
-@@ -195,7 +195,7 @@
- player().set_loop_status("None");
- player().set_rate(1.0);
- const auto executeCommand = [=](
-- GObject::Object,
-+ gi::repository::GObject::Object,
- Gio::DBusMethodInvocation invocation) {
- base::Integration::Instance().enterFromEventLoop([&] {
- _commandRequests.fire_copy(
-@@ -232,23 +232,23 @@
- return true;
- });
- player().property_loop_status().signal_notify().connect([=](
-- GObject::Object,
-- GObject::ParamSpec) {
-+ gi::repository::GObject::Object,
-+ gi::repository::GObject::ParamSpec) {
- base::Integration::Instance().enterFromEventLoop([&] {
- _commandRequests.fire_copy(
- LoopStatusToCommand(player().get_loop_status()));
- });
- });
- player().property_shuffle().signal_notify().connect([=](
-- GObject::Object,
-- GObject::ParamSpec) {
-+ gi::repository::GObject::Object,
-+ gi::repository::GObject::ParamSpec) {
- base::Integration::Instance().enterFromEventLoop([&] {
- _commandRequests.fire_copy(Command::Shuffle);
- });
- });
- player().property_volume().signal_notify().connect([=](
-- GObject::Object,
-- GObject::ParamSpec) {
-+ gi::repository::GObject::Object,
-+ gi::repository::GObject::ParamSpec) {
- base::Integration::Instance().enterFromEventLoop([&] {
- _volumeChangeRequests.fire_copy(player().get_volume());
- });
diff --git a/net-im/telegram-desktop/files/tdesktop-4.8.4-remove-private-qt.patch b/net-im/telegram-desktop/files/tdesktop-4.8.4-remove-private-qt.patch
deleted file mode 100644
index 3dcf17662564..000000000000
--- a/net-im/telegram-desktop/files/tdesktop-4.8.4-remove-private-qt.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Remove uses of private Qt classes
-
-Currently, this is used to fix compatibility with odd environments, and only
-for Qt6. This causes more trouble than it's worth, because it means telegram
-must be rebuilt with every minor Qt bump.
-
-https://bugs.gentoo.org/908500
-
---- tdesktop-4.8.4-full.orig/Telegram/lib_ui/ui/rp_widget.cpp
-+++ tdesktop-4.8.4-full/Telegram/lib_ui/ui/rp_widget.cpp
-@@ -12,38 +12,9 @@
-
- #include <QtGui/QWindow>
- #include <QtGui/QtEvents>
--#include <private/qwidget_p.h>
--
--class TWidgetPrivate : public QWidgetPrivate {
--public:
--#if QT_VERSION >= QT_VERSION_CHECK(6, 4, 0)
-- QPlatformBackingStoreRhiConfig rhiConfig() const override {
-- const auto q = static_cast<TWidget*>(q_ptr);
-- if (!q->testAttribute(Qt::WA_WState_Created)) {
-- return QWidgetPrivate::rhiConfig();
-- }
-- if (const auto config = q->rhiConfig()) {
-- return *config;
-- }
-- if (::Platform::IsMac10_14OrGreater()) {
-- return { QPlatformBackingStoreRhiConfig::Metal };
-- }
-- // We can't specify the widget here as q_evaluateRhiConfig is called
-- // in QWidgetWindow constructor, while windowHandle is set right after
-- // the constructor is completed
-- if (::Platform::IsWayland() // old versions of mutter produce flicker without OpenGL
-- && Ui::GL::ChooseBackendDefault(
-- Ui::GL::CheckCapabilities(nullptr))
-- == Ui::GL::Backend::OpenGL) {
-- return { QPlatformBackingStoreRhiConfig::OpenGL };
-- }
-- return QWidgetPrivate::rhiConfig();
-- }
--#endif // Qt >= 6.4.0
--};
-
- TWidget::TWidget(QWidget *parent)
--: TWidgetHelper<QWidget>(*(new TWidgetPrivate), parent, {}) {
-+: TWidgetHelper<QWidget>(parent, {}) {
- [[maybe_unused]] static const auto Once = [] {
- auto format = QSurfaceFormat::defaultFormat();
- format.setSwapInterval(0);
diff --git a/net-im/telegram-desktop/files/tdesktop-4.8.4-system-cppgir.patch b/net-im/telegram-desktop/files/tdesktop-4.8.4-system-cppgir.patch
deleted file mode 100644
index d8bd00aae907..000000000000
--- a/net-im/telegram-desktop/files/tdesktop-4.8.4-system-cppgir.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Use system cppgir
-
---- tdesktop-4.8.4-full.orig/cmake/external/glib/CMakeLists.txt
-+++ tdesktop-4.8.4-full/cmake/external/glib/CMakeLists.txt
-@@ -7,14 +7,6 @@
- add_library(external_glib INTERFACE IMPORTED GLOBAL)
- add_library(desktop-app::external_glib ALIAS external_glib)
-
--function(add_cppgir) # isolate scope
-- set(BUILD_TESTING OFF)
-- set(BUILD_DOC OFF)
-- set(CMAKE_DISABLE_FIND_PACKAGE_Qt5Core ON)
-- add_subdirectory(cppgir EXCLUDE_FROM_ALL)
--endfunction()
--add_cppgir()
--
- include(generate_cppgir.cmake)
- generate_cppgir(external_glib Gio-2.0)
-
---- tdesktop-4.8.4-full.orig/cmake/external/glib/generate_cppgir.cmake
-+++ tdesktop-4.8.4-full/cmake/external/glib/generate_cppgir.cmake
-@@ -4,6 +4,8 @@
- # For license and copyright information please follow this link:
- # https://github.com/desktop-app/legal/blob/master/LEGAL
-
-+find_package(CppGir REQUIRED)
-+
- function(generate_cppgir target_name gir)
- # cppgir generates all the dependent headers everytime, better to have a global folder
- set(gen_dst ${CMAKE_BINARY_DIR}/gen)
-@@ -32,17 +34,16 @@
- echo 1> ${gen_timestamp}
- COMMENT "Generating C++ wrapper for ${gir} (${target_name})"
- DEPENDS
-- cppgir
- ${gir_path}
- )
- generate_target(${target_name} cppgir ${gen_timestamp} "" ${gen_dst})
-
- get_target_property(target_type ${target_name} TYPE)
- if (${target_type} STREQUAL "INTERFACE_LIBRARY")
-- target_link_libraries(${target_name} INTERFACE gi)
-+ target_link_libraries(${target_name} INTERFACE CppGir::gi)
- target_compile_definitions(${target_name} INTERFACE GI_INLINE GI_OBJECT_NEWV)
- else()
-- target_link_libraries(${target_name} PUBLIC gi)
-+ target_link_libraries(${target_name} PUBLIC CppGir::gi)
- target_compile_definitions(${target_name} PUBLIC GI_INLINE GI_OBJECT_NEWV)
- endif()
- endfunction()