summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch b/net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch
new file mode 100644
index 000000000000..7ad3e75e49ba
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch
@@ -0,0 +1,35 @@
+Only link jemalloc for the Telegram binary
+
+Some combination of factors is making the different codegen tools hang when
+jemalloc is linked for those, and they're ran under portage's sandbox. Since
+this is only used during build-time, and jemalloc is merely necessary to
+improve runtime memory use, it's unnecessary to use it for anything else.
+
+--- tdesktop-3.1.0-full.orig/Telegram/CMakeLists.txt
++++ tdesktop-3.1.0-full/Telegram/CMakeLists.txt
+@@ -1256,6 +1256,11 @@
+ endif()
+ endif()
+ else()
++ target_link_libraries(Telegram
++ PRIVATE
++ desktop-app::external_jemalloc
++ )
++
+ if (NOT DESKTOP_APP_DISABLE_DBUS_INTEGRATION)
+ target_link_libraries(Telegram
+ PRIVATE
+--- tdesktop-3.1.0-full.orig/cmake/options_linux.cmake
++++ tdesktop-3.1.0-full/cmake/options_linux.cmake
+@@ -45,11 +45,6 @@
+ target_link_options(common_options INTERFACE $<IF:$<CONFIG:Debug>,,-g -flto -fuse-linker-plugin>)
+ endif()
+
+-target_link_libraries(common_options
+-INTERFACE
+- desktop-app::external_jemalloc
+-)
+-
+ if (DESKTOP_APP_USE_ALLOCATION_TRACER)
+ target_link_options(common_options
+ INTERFACE