summaryrefslogtreecommitdiff
path: root/net-im/poezio
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/poezio')
-rw-r--r--net-im/poezio/Manifest4
-rw-r--r--net-im/poezio/metadata.xml11
-rw-r--r--net-im/poezio/poezio-0.12.ebuild60
-rw-r--r--net-im/poezio/poezio-9999.ebuild60
4 files changed, 135 insertions, 0 deletions
diff --git a/net-im/poezio/Manifest b/net-im/poezio/Manifest
new file mode 100644
index 000000000000..3d0408343027
--- /dev/null
+++ b/net-im/poezio/Manifest
@@ -0,0 +1,4 @@
+DIST poezio-0.12.tar.gz 585750 BLAKE2B d79cab965b39a9ea191c763e1560bedbf46e3107e1b301a651103caf8f9e63b8465925ea01ac4e2e6b747b66cf5d4be8cabd8be80a069fe4eafcf331c7daada8 SHA512 6249daf23c6f4c1b25a9de686abaa62076e1eac7566da0a174ae3a82e3a53b7f2a86145d20d587a7ee43c8b679d90cb381d5afbfc7860459c5a497e97af32ff4
+EBUILD poezio-0.12.ebuild 1252 BLAKE2B 6517051d452341fe765b9ccfe0b96d5bee2c4ea084c80742c241c283d7010e0ff108af251d0124858f1387d67bc1a7297647148208dd759b01f106c65be2c71e SHA512 f7e996b9fb61d5586689d2f17a5e3b993129a1da5a0e92aa4d24bf86daa4482d1ac2e2ced0d55302c77224cb09dd6f2e9bfa89b1caf0f79ed6f8b8eb4e84e961
+EBUILD poezio-9999.ebuild 1252 BLAKE2B 6517051d452341fe765b9ccfe0b96d5bee2c4ea084c80742c241c283d7010e0ff108af251d0124858f1387d67bc1a7297647148208dd759b01f106c65be2c71e SHA512 f7e996b9fb61d5586689d2f17a5e3b993129a1da5a0e92aa4d24bf86daa4482d1ac2e2ced0d55302c77224cb09dd6f2e9bfa89b1caf0f79ed6f8b8eb4e84e961
+MISC metadata.xml 320 BLAKE2B 38b85fd661f7ca7a79c83a1070753f1049b7de9049f2d233f32d77ddd2a8cf72cfc8e3b7b27065a5583d6c631a6af0aa3ca70b907ca9c2a2e92f85471da542b2 SHA512 874c300be76a1b931ddebfb8867563696884267891a09e0879e1ceb0f581536ab9acacccb104e9609aef5c61c55e05ebd87d867d332141be9d52cea246dad09c
diff --git a/net-im/poezio/metadata.xml b/net-im/poezio/metadata.xml
new file mode 100644
index 000000000000..0f3aace8afd4
--- /dev/null
+++ b/net-im/poezio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">poezio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/poezio/poezio-0.12.ebuild b/net-im/poezio/poezio-0.12.ebuild
new file mode 100644
index 000000000000..d550ee29c570
--- /dev/null
+++ b/net-im/poezio/poezio-0.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
+HOMEPAGE="https://poez.io/"
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://git.poez.io/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/slixmpp[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/potr
+ dev-python/pyinotify
+ )"
+
+DOC_CONTENTS="
+Install these optional runtime dependencies for additional features.
+* dev-python/potr for OTR encryption support.
+* dev-python/pyinotify for screen autoaway plugin support.
+"
+DISABLE_AUTOFORMATTING=true
+
+src_prepare() {
+ default
+ # Delete unmaintained plugin which requires an excessive external dep
+ rm plugins/mpd_client.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/net-im/poezio/poezio-9999.ebuild b/net-im/poezio/poezio-9999.ebuild
new file mode 100644
index 000000000000..d550ee29c570
--- /dev/null
+++ b/net-im/poezio/poezio-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
+HOMEPAGE="https://poez.io/"
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://git.poez.io/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/slixmpp[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/potr
+ dev-python/pyinotify
+ )"
+
+DOC_CONTENTS="
+Install these optional runtime dependencies for additional features.
+* dev-python/potr for OTR encryption support.
+* dev-python/pyinotify for screen autoaway plugin support.
+"
+DISABLE_AUTOFORMATTING=true
+
+src_prepare() {
+ default
+ # Delete unmaintained plugin which requires an excessive external dep
+ rm plugins/mpd_client.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+python_test() {
+ esetup.py test
+}