summaryrefslogtreecommitdiff
path: root/net-im/neochat/neochat-24.02.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/neochat/neochat-24.02.0-r1.ebuild')
-rw-r--r--net-im/neochat/neochat-24.02.0-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-im/neochat/neochat-24.02.0-r1.ebuild b/net-im/neochat/neochat-24.02.0-r1.ebuild
new file mode 100644
index 000000000000..0ca370582e35
--- /dev/null
+++ b/net-im/neochat/neochat-24.02.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Client for Matrix, the decentralized communication protocol"
+HOMEPAGE="https://apps.kde.org/neochat/"
+
+LICENSE="GPL-3+ handbook? ( CC-BY-SA-4.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: Wire up kunifiedpush once packaged? (1a3055df8673802076bc0c269ec24274abef375b)
+DEPEND="
+ app-text/cmark:=
+ dev-libs/kirigami-addons:6
+ >=dev-libs/icu-61.0:=
+ dev-libs/qcoro[network]
+ >=dev-libs/qtkeychain-0.14.1-r1:=[qt6]
+ >=dev-qt/qtbase-${QTMIN}:6[gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtmultimedia-${QTMIN}:6
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=dev-qt/qtwebview-${QTMIN}:6
+ >=kde-frameworks/kcolorscheme-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/kitemmodels-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/qqc2-desktop-style-${KFMIN}:6
+ >=kde-frameworks/sonnet-${KFMIN}:6[qml]
+ media-libs/kquickimageeditor:6
+ >=net-libs/libquotient-0.8.1.2-r1:=[qt6]
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qt5compat-${QTMIN}:6[qml]
+ >=dev-qt/qtlocation-${QTMIN}:6
+ >=dev-qt/qtmultimedia-${QTMIN}:6[qml]
+ >=dev-qt/qtpositioning-${QTMIN}:6[qml]
+ >=kde-frameworks/kquickcharts-${KFMIN}:6
+ >=kde-frameworks/purpose-${KFMIN}:6
+ >=kde-frameworks/prison-${KFMIN}:6[qml]
+"
+BDEPEND="virtual/pkgconfig"