summaryrefslogtreecommitdiff
path: root/net-im/cpop/cpop-0.0.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/cpop/cpop-0.0.4-r2.ebuild')
-rw-r--r--net-im/cpop/cpop-0.0.4-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-im/cpop/cpop-0.0.4-r2.ebuild b/net-im/cpop/cpop-0.0.4-r2.ebuild
new file mode 100644
index 000000000000..77c21027edcc
--- /dev/null
+++ b/net-im/cpop/cpop-0.0.4-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GTK+ network popup message client. Compatible with the jpop protocol"
+HOMEPAGE="http://www.draxil.uklinux.net/hip/index.pl?page=cpop"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-implicit-exit_memset_strlen.patch
+ "${FILESDIR}"/${P}-implicit-func-decls.patch
+)
+
+src_prepare() {
+ default
+
+ # Clang 16, bug #900072
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}