summaryrefslogtreecommitdiff
path: root/net-im/bitlbee/bitlbee-3.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/bitlbee/bitlbee-3.5.1.ebuild')
-rw-r--r--net-im/bitlbee/bitlbee-3.5.1.ebuild30
1 files changed, 10 insertions, 20 deletions
diff --git a/net-im/bitlbee/bitlbee-3.5.1.ebuild b/net-im/bitlbee/bitlbee-3.5.1.ebuild
index 3ce9cca1ef23..5bae1f674e26 100644
--- a/net-im/bitlbee/bitlbee-3.5.1.ebuild
+++ b/net-im/bitlbee/bitlbee-3.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit user systemd toolchain-funcs
+inherit systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -30,6 +30,8 @@ REQUIRED_USE="
"
COMMON_DEPEND="
+ acct-group/bitlbee
+ acct-user/bitlbee
>=dev-libs/glib-2.16
purple? ( net-im/pidgin )
libevent? ( dev-libs/libevent:= )
@@ -52,20 +54,12 @@ RDEPEND="${COMMON_DEPEND}
virtual/logger
xinetd? ( sys-apps/xinetd )"
-pkg_setup() {
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
-src_prepare() {
- if [[ ${PV} != "9999" ]]; then
- eapply \
- "${FILESDIR}"/${PN}-3.5-systemd-user.patch \
- "${FILESDIR}"/${PN}-3.5-verbose-build.patch
- fi
-
- eapply_user
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-systemd-user.patch
+ "${FILESDIR}"/${PN}-3.5-verbose-build.patch
+ "${FILESDIR}"/${PN}-3.5-libcheck.patch
+ "${FILESDIR}"/${PN}-3.5-libevent.patch
+)
src_configure() {
local myconf
@@ -153,10 +147,6 @@ src_install() {
}
pkg_postinst() {
- chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
- [[ -d "${ROOT}"/var/run/bitlbee ]] &&
- chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
-
if [[ -z ${REPLACING_VERSIONS} ]]; then
einfo
elog "The bitlbee init script will now attempt to stop all processes owned by the"