summaryrefslogtreecommitdiff
path: root/net-ftp/scythia/scythia-0.9.3_p2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/scythia/scythia-0.9.3_p2.ebuild')
-rw-r--r--net-ftp/scythia/scythia-0.9.3_p2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-ftp/scythia/scythia-0.9.3_p2.ebuild b/net-ftp/scythia/scythia-0.9.3_p2.ebuild
new file mode 100644
index 000000000000..31d38020de70
--- /dev/null
+++ b/net-ftp/scythia/scythia-0.9.3_p2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit gnome2-utils qt4-r2
+
+DESCRIPTION="Just a small FTP client"
+HOMEPAGE="http://scythia.free.fr/"
+SRC_URI="http://scythia.free.fr/wp-content/${PN}_${PV/_p/-}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/usr/share/applnk/Internet:/usr/share/applications:g' \
+ -e "s:scythia/html:${PF}/html:" \
+ scythia.pro || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}