summaryrefslogtreecommitdiff
path: root/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild')
-rw-r--r--net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild b/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild
new file mode 100644
index 000000000000..bd44189dc92f
--- /dev/null
+++ b/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils qmake-utils
+
+DESCRIPTION="The somehow different FTP client"
+HOMEPAGE="http://oneclickftp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-crypt/qca:2[qt4(+)]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-qt47.patch"
+)
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ doicon res/icons/${PN}.png
+ make_desktop_entry ${PN} ${PN}
+
+ einstalldocs
+}