summaryrefslogtreecommitdiff
path: root/net-ftp/lftp/lftp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp/lftp-9999.ebuild')
-rw-r--r--net-ftp/lftp/lftp-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-ftp/lftp/lftp-9999.ebuild b/net-ftp/lftp/lftp-9999.ebuild
index 4f73a82a139b..ae490e6c7f39 100644
--- a/net-ftp/lftp/lftp-9999.ebuild
+++ b/net-ftp/lftp/lftp-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils git-r3 libtool
+EAPI=7
+inherit autotools git-r3 libtool xdg-utils
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
HOMEPAGE="https://lftp.tech/"
@@ -95,3 +95,11 @@ src_install() {
use ${script} || { rm "${ED}"/usr/share/${PN}/${script} || die ;}
done
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}