summaryrefslogtreecommitdiff
path: root/net-ftp/lftp/lftp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp/lftp-9999.ebuild')
-rw-r--r--net-ftp/lftp/lftp-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-ftp/lftp/lftp-9999.ebuild b/net-ftp/lftp/lftp-9999.ebuild
index c1915ac399f9..3020137e83ad 100644
--- a/net-ftp/lftp/lftp-9999.ebuild
+++ b/net-ftp/lftp/lftp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ EGIT_REPO_URI="https://github.com/lavv17/lftp"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="convert-mozilla-cookies +gnutls idn ipv6 nls socks5 +ssl verify-file"
+IUSE="convert-mozilla-cookies +gnutls idn nls socks5 +ssl verify-file"
RDEPEND="
>=sys-libs/ncurses-5.1:=
@@ -57,6 +57,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.9.1-libdir-readline.patch
)
+# Gnulib false positive #900064
+QA_CONFIG_IMPL_DECL_SKIP="( MIN )"
+
src_prepare() {
default
@@ -73,12 +76,12 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable ipv6) \
$(use_enable nls) \
$(use_with idn libidn2) \
$(use_with socks5 socksdante "${EPREFIX}"/usr) \
$(usex ssl "$(use_with !gnutls openssl "${EPREFIX}"/usr)" '--without-openssl') \
$(usex ssl "$(use_with gnutls)" '--without-gnutls') \
+ --enable-ipv6
--enable-packager-mode \
--sysconfdir="${EPREFIX}"/etc/${PN} \
--with-modules \