summaryrefslogtreecommitdiff
path: root/net-fs/mc/mc-0_pre20180325.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/mc/mc-0_pre20180325.ebuild')
-rw-r--r--net-fs/mc/mc-0_pre20180325.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/net-fs/mc/mc-0_pre20180325.ebuild b/net-fs/mc/mc-0_pre20180325.ebuild
deleted file mode 100644
index 3ac577093d58..000000000000
--- a/net-fs/mc/mc-0_pre20180325.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot bash-completion-r1
-
-EGO_PN="github.com/minio/mc"
-VERSION="2018-03-25T01-22-22Z"
-EGIT_COMMIT="da5c19848d1e82a24eddb453b01e83d4a0660de4"
-ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Minio client provides alternatives for ls, cat on cloud storage and filesystems"
-HOMEPAGE="https://github.com/minio/mc"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-RESTRICT="test"
-
-RDEPEND="!!app-misc/mc"
-
-src_prepare() {
- default
- sed -i -e "s/time.Now().UTC().Format(time.RFC3339)/\"${VERSION}\"/"\
- -e "s/-s //"\
- -e "/time/d"\
- -e "s/+ commitID()/+ \"${EGIT_COMMIT}\"/"\
- src/${EGO_PN}/buildscripts/gen-ldflags.go || die
-}
-
-src_compile() {
- pushd src/${EGO_PN} || die
- MC_RELEASE="${VERSION}"
- GOPATH="${S}" go build --ldflags "$(go run buildscripts/gen-ldflags.go)" -o ${PN} || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dodoc -r README.md CONTRIBUTING.md docs
- dobin mc
- newbashcomp autocomplete/bash_autocomplete ${PN}
- popd || die
-}