summaryrefslogtreecommitdiff
path: root/net-firewall/nftables
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/nftables')
-rw-r--r--net-firewall/nftables/Manifest1
-rw-r--r--net-firewall/nftables/nftables-1.1.0.ebuild228
2 files changed, 0 insertions, 229 deletions
diff --git a/net-firewall/nftables/Manifest b/net-firewall/nftables/Manifest
index 21e79f6d64ea..c669a7a94571 100644
--- a/net-firewall/nftables/Manifest
+++ b/net-firewall/nftables/Manifest
@@ -13,6 +13,5 @@ DIST nftables-1.1.0.tar.xz 1057672 BLAKE2B cc876d9ba344480a2f5a12811206356d9edbd
DIST nftables-1.1.0.tar.xz.sig 566 BLAKE2B 556287b40ad6f82d229ae18910ec2008c3168c7088e7149f8b5e80ca9983b90ec202cf01838c80e973845dd565f4f13a454d6dc99030a3f9cede6c33929da07d SHA512 1b3a42a76b378373c8a21b77aaf9c1fc57402360d49d56b22f02c50bef969b1f6867a4d40bda24b2dd1a0dfcf7148893938a7eea84ff8cc67d9edcd6b9b62bb4
EBUILD nftables-1.0.9.ebuild 6478 BLAKE2B 67415f3877ba9d24eb995bb97f4bd93520d9fc70d7fde48b743779879886aad83d4cb3b5bcebbb3b63d27038d2e556c99b01979e539db1054058759b3830a663 SHA512 cd4ee3af488cc918cead56406f54a5b74dc54e3aabab3e63e7b704922add8cb652d509ea87b6c3227455bf0805b12fb328a94992062cc09c3ed9710be4bc7b85
EBUILD nftables-1.1.0-r1.ebuild 6570 BLAKE2B a4fb963a29cfedf3a596377479ad8419b3609ada67362d499ab0a0ff7150a2effa9c23f662c199d808c878256b89b3d5526b8f3fe7ccf1950ba39383ebbb6435 SHA512 5ecd1232140316d7b9b9fe07c2ab44e702c099f11b62f7a5c21f12a253bdbddacd52d8a1d4573d5917eb4bde470c35c4841bd5f1032a0eb9d47c009a01f1efd6
-EBUILD nftables-1.1.0.ebuild 6488 BLAKE2B eb5ca8ea1b6bd0ef187bc45aed113b0e24e691d958cd08c32b5f67bdbd2b22b25fbc438f77f5c54cd1e87cdda5b89e48a2d86dc58d04520920bcca09bb0ad0f6 SHA512 47848d0eb477c62ecc3250aa0bc2cfc20b4ec5226e377e3f533ee2e4c79189e2beb41ef77d424a8258bab8b1401cadff837fc327fa20eaa9faad00b2c9d34e05
EBUILD nftables-9999.ebuild 6488 BLAKE2B eb5ca8ea1b6bd0ef187bc45aed113b0e24e691d958cd08c32b5f67bdbd2b22b25fbc438f77f5c54cd1e87cdda5b89e48a2d86dc58d04520920bcca09bb0ad0f6 SHA512 47848d0eb477c62ecc3250aa0bc2cfc20b4ec5226e377e3f533ee2e4c79189e2beb41ef77d424a8258bab8b1401cadff837fc327fa20eaa9faad00b2c9d34e05
MISC metadata.xml 684 BLAKE2B 96044107a07596178b59f3d4bed0433e06eb74693fafcc1a8c20468e02626814ba1544bba54c64367e43a126463b0f3b33e340476aff15db934467e8b9d46bf7 SHA512 fa4c9cadddccda4217837a892fbec3e1b984fb18a4d11d5536f22724d2455724eb59c5cc06da5830fb28bb48cb2d01374fdc56e216296c695c678af28390392a
diff --git a/net-firewall/nftables/nftables-1.1.0.ebuild b/net-firewall/nftables/nftables-1.1.0.ebuild
deleted file mode 100644
index 60c4f92e0ca9..000000000000
--- a/net-firewall/nftables/nftables-1.1.0.ebuild
+++ /dev/null
@@ -1,228 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_OPTIONAL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/netfilter.org.asc
-inherit edo linux-info distutils-r1 systemd verify-sig
-
-DESCRIPTION="Linux kernel firewall, NAT and packet mangling tools"
-HOMEPAGE="https://netfilter.org/projects/nftables/"
-
-if [[ ${PV} =~ ^[9]{4,}$ ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://git.netfilter.org/${PN}"
- BDEPEND="app-alternatives/yacc"
-else
- SRC_URI="
- https://netfilter.org/projects/nftables/files/${P}.tar.xz
- verify-sig? ( https://netfilter.org/projects/nftables/files/${P}.tar.xz.sig )
- "
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
- BDEPEND="verify-sig? ( sec-keys/openpgp-keys-netfilter )"
-fi
-
-# See COPYING: new code is GPL-2+, existing code is GPL-2
-LICENSE="GPL-2 GPL-2+"
-SLOT="0/1"
-IUSE="debug doc +gmp json libedit python +readline static-libs test xtables"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=net-libs/libmnl-1.0.4:=
- >=net-libs/libnftnl-1.2.7:=
- gmp? ( dev-libs/gmp:= )
- json? ( dev-libs/jansson:= )
- python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:= )
- xtables? ( >=net-firewall/iptables-1.6.1:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND+="
- app-alternatives/lex
- virtual/pkgconfig
- doc? (
- app-text/asciidoc
- >=app-text/docbook2X-0.8.8-r4
- )
- python? ( ${DISTUTILS_DEPS} )
-"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- libedit? ( !readline )
-"
-
-src_prepare() {
- default
-
- if [[ ${PV} =~ ^[9]{4,}$ ]] ; then
- eautoreconf
- fi
-
- if use python; then
- pushd py >/dev/null || die
- distutils-r1_src_prepare
- popd >/dev/null || die
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- --sbindir="${EPREFIX}"/sbin
- $(use_enable debug)
- $(use_enable doc man-doc)
- $(use_with !gmp mini_gmp)
- $(use_with json)
- $(use_with libedit cli editline)
- $(use_with readline cli readline)
- $(use_enable static-libs static)
- $(use_with xtables)
- )
-
- econf "${myeconfargs[@]}"
-
- if use python; then
- pushd py >/dev/null || die
- distutils-r1_src_configure
- popd >/dev/null || die
- fi
-}
-
-src_compile() {
- default
-
- if use python; then
- pushd py >/dev/null || die
- distutils-r1_src_compile
- popd >/dev/null || die
- fi
-}
-
-src_test() {
- emake check
-
- if [[ ${EUID} == 0 ]]; then
- edo tests/shell/run-tests.sh -v
- else
- ewarn "Skipping shell tests (requires root)"
- fi
-
- if use python; then
- pushd tests/py >/dev/null || die
- distutils-r1_src_test
- popd >/dev/null || die
- fi
-}
-
-python_test() {
- if [[ ${EUID} == 0 ]]; then
- edo "${EPYTHON}" nft-test.py
- else
- ewarn "Skipping Python tests (requires root)"
- fi
-}
-
-src_install() {
- default
-
- if ! use doc && [[ ! ${PV} =~ ^[9]{4,}$ ]]; then
- pushd doc >/dev/null || die
- doman *.?
- popd >/dev/null || die
- fi
-
- # Do it here instead of in src_prepare to avoid eautoreconf
- # rmdir lets us catch if more files end up installed in /etc/nftables
- dodir /usr/share/doc/${PF}/skels/
- mv "${ED}"/etc/nftables/osf "${ED}"/usr/share/doc/${PF}/skels/osf || die
- rmdir "${ED}"/etc/nftables || die
-
- exeinto /usr/libexec/${PN}
- newexe "${FILESDIR}"/libexec/${PN}-mk.sh ${PN}.sh
- newconfd "${FILESDIR}"/${PN}-mk.confd ${PN}
- newinitd "${FILESDIR}"/${PN}-mk.init-r1 ${PN}
- keepdir /var/lib/nftables
-
- systemd_dounit "${FILESDIR}"/systemd/${PN}-restore.service
-
- if use python ; then
- pushd py >/dev/null || die
- distutils-r1_src_install
- popd >/dev/null || die
- fi
-
- find "${ED}" -type f -name "*.la" -delete || die
-}
-
-pkg_preinst() {
- local stderr
-
- # There's a history of regressions with nftables upgrades. Perform a
- # safety check to help us spot them earlier. For the check to pass, the
- # currently loaded ruleset, if any, must be successfully evaluated by
- # the newly built instance of nft(8).
- if [[ -n ${ROOT} ]] || [[ ! -d /sys/module/nftables ]] || [[ ! -x /sbin/nft ]]; then
- # Either nftables isn't yet in use or nft(8) cannot be executed.
- return
- elif ! stderr=$(umask 177; /sbin/nft -t list ruleset 2>&1 >"${T}"/ruleset.nft); then
- # Report errors induced by trying to list the ruleset but don't
- # treat them as being fatal.
- printf '%s\n' "${stderr}" >&2
- elif [[ ${stderr} == *"is managed by iptables-nft"* ]]; then
- # Rulesets generated by iptables-nft are special in nature and
- # will not always be printed in a way that constitutes a valid
- # syntax for ntf(8). Ignore them.
- return
- elif set -- "${ED}"/usr/lib*/libnftables.so;
- ! LD_LIBRARY_PATH=${1%/*} "${ED}"/sbin/nft -c -f -- "${T}"/ruleset.nft
- then
- eerror "Your currently loaded ruleset cannot be parsed by the newly built instance of"
- eerror "nft. This probably means that there is a regression introduced by v${PV}."
- eerror "(To make the ebuild fail instead of warning, set NFTABLES_ABORT_ON_RELOAD_FAILURE=1.)"
- if [[ -n ${NFTABLES_ABORT_ON_RELOAD_FAILURE} ]] ; then
- die "Aborting because of failed nft reload!"
- fi
- fi
-}
-
-pkg_postinst() {
- local save_file
- save_file="${EROOT}"/var/lib/nftables/rules-save
-
- # In order for the nftables-restore systemd service to start
- # the save_file must exist.
- if [[ ! -f "${save_file}" ]]; then
- ( umask 177; touch "${save_file}" )
- elif [[ $(( "$( stat --printf '%05a' "${save_file}" )" & 07177 )) -ne 0 ]]; then
- ewarn "Your system has dangerous permissions for ${save_file}"
- ewarn "It is probably affected by bug #691326."
- ewarn "You may need to fix the permissions of the file. To do so,"
- ewarn "you can run the command in the line below as root."
- ewarn " 'chmod 600 \"${save_file}\"'"
- fi
-
- if has_version 'sys-apps/systemd'; then
- elog "If you wish to enable the firewall rules on boot (on systemd) you"
- elog "will need to enable the nftables-restore service."
- elog " 'systemctl enable ${PN}-restore.service'"
- elog
- elog "If you are creating firewall rules before the next system restart"
- elog "the nftables-restore service must be manually started in order to"
- elog "save those rules on shutdown."
- fi
-
- if has_version 'sys-apps/openrc'; then
- elog "If you wish to enable the firewall rules on boot (on openrc) you"
- elog "will need to enable the nftables service."
- elog " 'rc-update add ${PN} default'"
- elog
- elog "If you are creating or updating the firewall rules and wish to save"
- elog "them to be loaded on the next restart, use the \"save\" functionality"
- elog "in the init script."
- elog " 'rc-service ${PN} save'"
- fi
-}