summaryrefslogtreecommitdiff
path: root/net-firewall/nfacct/nfacct-1.0.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/nfacct/nfacct-1.0.2-r2.ebuild')
-rw-r--r--net-firewall/nfacct/nfacct-1.0.2-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-firewall/nfacct/nfacct-1.0.2-r2.ebuild b/net-firewall/nfacct/nfacct-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..a6dc39569c14
--- /dev/null
+++ b/net-firewall/nfacct/nfacct-1.0.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Command line tool to create/retrieve/delete accounting objects in NetFilter"
+HOMEPAGE="https://www.netfilter.org/projects/nfacct/"
+SRC_URI="https://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc64 x86"
+
+RDEPEND="
+ net-libs/libmnl:=
+ >=net-libs/libnetfilter_acct-1.0.3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK_ACCT"
+
+src_install() {
+ default
+
+ keepdir /var/lib/nfacct
+ newinitd "${FILESDIR}"/${PN}.initd nfacct
+ newconfd "${FILESDIR}"/${PN}.confd nfacct
+}