summaryrefslogtreecommitdiff
path: root/net-firewall/nfacct/nfacct-1.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/nfacct/nfacct-1.0.2-r1.ebuild')
-rw-r--r--net-firewall/nfacct/nfacct-1.0.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-firewall/nfacct/nfacct-1.0.2-r1.ebuild b/net-firewall/nfacct/nfacct-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..1feb53596a4b
--- /dev/null
+++ b/net-firewall/nfacct/nfacct-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info
+
+DESCRIPTION="Command line tool to create/retrieve/delete accounting objects in NetFilter"
+HOMEPAGE="https://www.netfilter.org/projects/nfacct/"
+SRC_URI="https://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc64 x86"
+
+RDEPEND="
+ net-libs/libmnl
+ >=net-libs/libnetfilter_acct-1.0.3
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+CONFIG_CHECK="~NETFILTER_NETLINK_ACCT"
+
+src_install() {
+ default_src_install
+
+ keepdir /var/lib/nfacct
+ newinitd "${FILESDIR}"/${PN}.initd nfacct
+ newconfd "${FILESDIR}"/${PN}.confd nfacct
+}