summaryrefslogtreecommitdiff
path: root/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/ipt_netflow/ipt_netflow-9999.ebuild')
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-9999.ebuild27
1 files changed, 21 insertions, 6 deletions
diff --git a/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild b/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
index 71ba1b74afbf..06411e1ae6d9 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
@@ -27,16 +27,27 @@ DEPEND="${RDEPEND}
"
PATCHES=(
"${FILESDIR}/${PN}-2.0-configure.patch" # bug #455984
- "${FILESDIR}/${PN}-2.3-flags.patch"
+ "${FILESDIR}/${PN}-9999-flags.patch"
)
pkg_setup() {
+ linux-info_pkg_setup
+
+ local CONFIG_CHECK="~IP_NF_IPTABLES VLAN_8021Q"
+ use debug && CONFIG_CHECK+=" ~DEBUG_FS"
+ if use natevents; then
+ CONFIG_CHECK+=" NF_CONNTRACK_EVENTS"
+ if kernel_is lt 5 2; then
+ CONFIG_CHECK+=" NF_NAT_NEEDED"
+ else
+ CONFIG_CHECK+=" NF_NAT"
+ fi
+ fi
+
BUILD_TARGETS="all"
MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
IPT_LIB="/usr/$(get_libdir)/xtables"
- local CONFIG_CHECK="~IP_NF_IPTABLES VLAN_8021Q"
- use debug && CONFIG_CHECK+=" ~DEBUG_FS"
- use natevents && CONFIG_CHECK+=" NF_CONNTRACK_EVENTS NF_NAT_NEEDED"
+
linux-mod_pkg_setup
}
@@ -44,10 +55,14 @@ src_prepare() {
default
# Fix incorrect module version in sources
- sed -i -e "/IPT_NETFLOW_VERSION/s/2.2/${PV}/" ipt_NETFLOW.c || die
+ sed -i \
+ -e '/IPT_NETFLOW_VERSION/s#"[0-9.]*"#"'${PV}'"#' \
+ ipt_NETFLOW.c || die
# Checking for directory is enough
- sed -i -e 's:-s /etc/snmp/snmpd.conf:-d /etc/snmp:' configure || die
+ sed -i \
+ -e 's:-s /etc/snmp/snmpd.conf:-d /etc/snmp:' \
+ configure || die
}
do_conf() {