summaryrefslogtreecommitdiff
path: root/net-dns/totd/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/totd/files')
-rw-r--r--net-dns/totd/files/totd38
-rw-r--r--net-dns/totd/files/totd-1.5.1-no_werror.patch11
2 files changed, 49 insertions, 0 deletions
diff --git a/net-dns/totd/files/totd b/net-dns/totd/files/totd
new file mode 100644
index 000000000000..79d410acb013
--- /dev/null
+++ b/net-dns/totd/files/totd
@@ -0,0 +1,38 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f /etc/totd.conf ]
+ then
+ eerror "The config file /etc/totd.conf does not exist."
+ return 1
+ else
+ return 0
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting totd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/totd
+ eend $?
+}
+
+stop() {
+ local pid_file
+ pid_file="`grep ^pidfile /etc/totd.conf | cut -f2 -d ' '`"
+ ebegin "Stopping totd"
+ if [ -n "$pid_file" ]
+ then
+ start-stop-daemon --stop --quiet --pidfile $pid_file
+ else
+ start-stop-daemon --stop --quiet --pidfile /var/run/totd.pid
+ fi
+ eend $?
+}
diff --git a/net-dns/totd/files/totd-1.5.1-no_werror.patch b/net-dns/totd/files/totd-1.5.1-no_werror.patch
new file mode 100644
index 000000000000..246e709d5109
--- /dev/null
+++ b/net-dns/totd/files/totd-1.5.1-no_werror.patch
@@ -0,0 +1,11 @@
+--- totd-1.5.1/Makefile.in 2005-01-31 12:55:14.000000000 +0100
++++ totd-1.5.1_new/Makefile.in 2007-06-30 22:51:07.000000000 +0200
+@@ -19,7 +19,7 @@
+
+ INSTALL = /usr/bin/install
+
+-CFLAGS = @CFLAGS@ @DEFS@ -Werror -Wall -DTOTCONF=\"$(TOT_CONFIG_FILE)\" @OPTFLAGS@ $(INCLUDEPATH)
++CFLAGS = @CFLAGS@ @DEFS@ -Wall -DTOTCONF=\"$(TOT_CONFIG_FILE)\" @OPTFLAGS@ $(INCLUDEPATH)
+
+ # When debugging is enabled by --enable-malloc-debug flag to the configure
+ # script, the @DBMALLOC@ substitution will contain the empty string, thus