summaryrefslogtreecommitdiff
path: root/net-dns/odsclient/odsclient-1.03-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/odsclient/odsclient-1.03-r1.ebuild')
-rw-r--r--net-dns/odsclient/odsclient-1.03-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-dns/odsclient/odsclient-1.03-r1.ebuild b/net-dns/odsclient/odsclient-1.03-r1.ebuild
new file mode 100644
index 000000000000..d679353f7246
--- /dev/null
+++ b/net-dns/odsclient/odsclient-1.03-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Client for the Open Domain Server's dynamic dns"
+HOMEPAGE="http://www.ods.org/"
+SRC_URI="http://www.ods.org/dl/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile -e 's| -o | $(LDFLAGS)&|g' || die "sed failed"
+
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ dosbin odsclient
+ dodoc README
+}