summaryrefslogtreecommitdiff
path: root/net-dns/ndu
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/ndu')
-rw-r--r--net-dns/ndu/Manifest3
-rw-r--r--net-dns/ndu/files/ndu-0.4-fix-pointer-comparison-with-0.patch26
-rw-r--r--net-dns/ndu/ndu-0.4-r4.ebuild5
3 files changed, 31 insertions, 3 deletions
diff --git a/net-dns/ndu/Manifest b/net-dns/ndu/Manifest
index 3c539dbadaeb..b3fa6a98e014 100644
--- a/net-dns/ndu/Manifest
+++ b/net-dns/ndu/Manifest
@@ -1,4 +1,5 @@
AUX ndu-0.4-binary-locations.patch 426 BLAKE2B 6d8c5648b0c25129c87e73f3ac47f2baf699890fcf0023dbe801e7c3cfb4f32ca15287e5a70b9b7829364956a89ab9d04bc6088291890c1e4e949972823a76ed SHA512 58e248d48491759c33ae2ee2d57fdca38b718104606c05d965bc7b555cfd72388a906efd692d789d999fe782878e173438cc22f1091d278eed8b4322ec6f6294
+AUX ndu-0.4-fix-pointer-comparison-with-0.patch 657 BLAKE2B b3b912c0aa474d8ff2a9763947892b807fbb96221d6bc78ac7cbdf2049f5c36131172ff590a482587c03eee492a76ee19ae34f18d341fa5ed55edbf2966a04cd SHA512 d33f3f8ff4d467eaa6e3f55c736e65abe4de2442b94c57afa90cbc93d88e246ef6de6090ae2d51a9d2357c79ae3d8afad77f237e0ac2b7a0ccc9246b0b40fe2e
DIST ndu-0.4.tar.gz 16118 BLAKE2B 7355d1d091f4b0865e3692b80a0dd4734e3e13464757adb1b9d712545ff4f827b828070f0bd027b077acb99c8d4ccd2ed645b3c7f114bfac65707ae7853ea3f2 SHA512 cf401f89f1d6ae66c5440e6ef43f1c78e071d13dd2b1d816f1c3bfd2a0b2d7d7a9d2be9025b3d88f3fbd186ff610ac92858e13b4e47b23b9088f91f3e1a40f39
-EBUILD ndu-0.4-r4.ebuild 1731 BLAKE2B c6a2f0d424b223faf2f0972ee55e6a01652185ccf4b9836fbe70ae001788f54183244beadcf0adf829d4d6891cbcf3fa8f882e2ae3f4f38fb55642bd37af3613 SHA512 fd0a396c008888f8d3a3cbbb78ca679dfb30de73972b8a4986f677fd58d0c64f501bfcf70ead4989d179205d8180d810446bd9ecdd442576b7739f932eed15cc
+EBUILD ndu-0.4-r4.ebuild 1787 BLAKE2B a598991619fa65433b569c0f122faeabbdc1300f7a80c3ace9c5df5f522463a17da711bc74782a48c363085844a53208bdd764b3ef51a75bafb806191be81fa5 SHA512 df4925aaa880b20325aba5fa116637dee87fa56aadf169236f088e136071c8b6b932e1a84baa4aa96f5f05344b55d581bd7f9aa82d40b87b3b56f18df48608ef
MISC metadata.xml 268 BLAKE2B 914b6995ad966e2b83ec718b2598969b181c119d8805241b0046f69e161ac22a9f769204f4783240056804008475aa406cbd91b9de499ec7840f9595158bd291 SHA512 ffda1db3fd6ac952f41a970e2e496c6a9fd0b12ed11cdf363fd269c3b00f627c6e70421fd545aad61d69594af2e5f43d8ebc197232a39b596d012818fe758850
diff --git a/net-dns/ndu/files/ndu-0.4-fix-pointer-comparison-with-0.patch b/net-dns/ndu/files/ndu-0.4-fix-pointer-comparison-with-0.patch
new file mode 100644
index 000000000000..1d7a40d7aed4
--- /dev/null
+++ b/net-dns/ndu/files/ndu-0.4-fix-pointer-comparison-with-0.patch
@@ -0,0 +1,26 @@
+From 5df37d4e6a22a67671a4b74c68e725a9001fbac1 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 15 Jun 2021 02:38:33 +0000
+Subject: [PATCH] Fix pointer comparison with 0
+
+Closes: https://bugs.gentoo.org/786276
+---
+ src/ndu.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/ndu.cpp b/src/ndu.cpp
+index 558ee45..8d3b353 100644
+--- a/src/ndu.cpp
++++ b/src/ndu.cpp
+@@ -404,7 +404,7 @@ public:
+ {
+ // see if file is a reverse file
+ // if the zone ends in .in-addr.arpa
+- if(strstr(name->pchar(), IN_ADDR_ARPA) > 0)
++ if(strstr(name->pchar(), IN_ADDR_ARPA) != 0)
+ {
+ zoneType = 1;
+ }
+--
+2.32.0
+
diff --git a/net-dns/ndu/ndu-0.4-r4.ebuild b/net-dns/ndu/ndu-0.4-r4.ebuild
index c63454d29b29..c8510ed983e7 100644
--- a/net-dns/ndu/ndu-0.4-r4.ebuild
+++ b/net-dns/ndu/ndu-0.4-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,13 +12,14 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
RDEPEND="sys-apps/ed" # dnstouch calls ed to do the dirty work
src_prepare() {
default
+
eapply "${FILESDIR}"/${P}-binary-locations.patch
+ eapply "${FILESDIR}"/${P}-fix-pointer-comparison-with-0.patch
# match our bind config
sed -e 's|0.0.127.in-addr.arpa|127.in-addr.arpa|g' -i ndu.conf || die