summaryrefslogtreecommitdiff
path: root/net-dns/dnstop/dnstop-20140915-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnstop/dnstop-20140915-r2.ebuild')
-rw-r--r--net-dns/dnstop/dnstop-20140915-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-dns/dnstop/dnstop-20140915-r2.ebuild b/net-dns/dnstop/dnstop-20140915-r2.ebuild
new file mode 100644
index 000000000000..0d25543b4a68
--- /dev/null
+++ b/net-dns/dnstop/dnstop-20140915-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Displays various tables of DNS traffic on your network"
+HOMEPAGE="http://dnstop.measurement-factory.com/"
+SRC_URI="http://dnstop.measurement-factory.com/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0
+ net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}"-pkg-config.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-ipv6
+}
+
+src_install() {
+ dobin dnstop
+ doman dnstop.8
+ dodoc CHANGES
+}