summaryrefslogtreecommitdiff
path: root/net-dns/dnsimple-dyndns/dnsimple-dyndns-0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnsimple-dyndns/dnsimple-dyndns-0.1.ebuild')
-rw-r--r--net-dns/dnsimple-dyndns/dnsimple-dyndns-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-dns/dnsimple-dyndns/dnsimple-dyndns-0.1.ebuild b/net-dns/dnsimple-dyndns/dnsimple-dyndns-0.1.ebuild
new file mode 100644
index 000000000000..c7a62597feac
--- /dev/null
+++ b/net-dns/dnsimple-dyndns/dnsimple-dyndns-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+GIT_ECLASS=
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
+fi
+
+inherit distutils-r1 ${GIT_ECLASS}
+
+DESCRIPTION="Dynamic DNS implementation, that relies on DNSimple.com"
+HOMEPAGE="https://pypi.python.org/pypi/dnsimple-dyndns
+ https://github.com/rafaelmartins/dnsimple-dyndns"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/requests-2.0.0"
+RDEPEND="${DEPEND}"