summaryrefslogtreecommitdiff
path: root/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild')
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
index 3d902b82aaef..b5bda3db325f 100644
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-EGO_PN="github.com/jedisct1/${PN}"
+EGO_PN="github.com/DNSCrypt/${PN}"
inherit fcaps go-module systemd
@@ -30,11 +30,12 @@ RDEPEND="
"
FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+PATCHES=( "${FILESDIR}"/config-full-paths-r11.patch )
src_compile() {
pushd "${PN}" >/dev/null || die
- go build -buildmode="$(usex pie pie default)" || die
+ go build -v -x -mod=readonly -mod=vendor -buildmode="$(usex pie pie default)" || die
popd >/dev/null || die
}
@@ -95,5 +96,5 @@ pkg_postinst() {
elog
elog "nameserver 127.0.0.1"
elog
- elog "Also see https://github.com/jedisct1/${PN}/wiki"
+ elog "Also see https://github.com/DNSCrypt/${PN}/wiki"
}