summaryrefslogtreecommitdiff
path: root/net-dns/coredns/coredns-010.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/coredns/coredns-010.ebuild')
-rw-r--r--net-dns/coredns/coredns-010.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-dns/coredns/coredns-010.ebuild b/net-dns/coredns/coredns-010.ebuild
new file mode 100644
index 000000000000..2e74aadba5e9
--- /dev/null
+++ b/net-dns/coredns/coredns-010.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_VENDOR=( "github.com/mholt/caddy bd67ec99f01797931a0787b9c2de0f04fa0e5980" )
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-build golang-vcs-snapshot
+
+EGIT_COMMIT="v${PV}"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A DNS server that chains middleware"
+HOMEPAGE="https://github.com/coredns/coredns"
+
+SRC_URI="${ARCHIVE_URI}
+ ${EGO_VENDOR_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN}
+ dobin ${PN}
+ dodoc README.md
+ popd || die
+}