summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin43740 -> 43736 bytes
-rw-r--r--net-analyzer/monitoring-plugins/Manifest1
-rw-r--r--net-analyzer/monitoring-plugins/files/define-own-mysql-port-constant.patch102
-rw-r--r--net-analyzer/nagstamon/Manifest2
-rw-r--r--net-analyzer/nagstamon/files/nagstamon-3.0-setup.patch27
-rw-r--r--net-analyzer/nagstamon/files/nagstamon-3.4.1-unknown-version-id.patch14
-rw-r--r--net-analyzer/openvas-scanner/Manifest8
-rw-r--r--net-analyzer/openvas-scanner/files/gvm-feed-sync-20.8.1.sh45
-rw-r--r--net-analyzer/openvas-scanner/files/gvm-feed-sync.cron1
-rw-r--r--net-analyzer/openvas-scanner/files/gvm-feed-sync.sh45
-rw-r--r--net-analyzer/openvas-scanner/files/openvassd-daemon.conf17
-rw-r--r--net-analyzer/openvas-scanner/files/openvassd.gvm.conf124
-rw-r--r--net-analyzer/openvas-scanner/files/openvassd.init14
-rw-r--r--net-analyzer/openvas-scanner/files/openvassd.service16
-rw-r--r--net-analyzer/openvas-scanner/files/redis.conf.example57
15 files changed, 0 insertions, 473 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index fb8a4d87d24e..93fd433e2aa2 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index 321d7e0d2e1c..11ed1a406e99 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1,4 +1,3 @@
-AUX define-own-mysql-port-constant.patch 3296 BLAKE2B 7a7c88c6f2c71bc1fc2f802ad202c2d2dbf3ede5af55dbe46cc15a064d37178b27670e30aa7bea07147456ce4d3e1ce9f495fa6df9deb4095367a7427e217719 SHA512 3ead6340800ac15fbe76e223599a5b3dbc6b6b13b72b684919aa43487838564ad7117b4e67fa7f36f0f58554fd8b8d6233efbcb82e6927a0c31f22c6a9ab5dbb
AUX monitoring-plugins-fix-check-disk-on-btrfs.patch 913 BLAKE2B 7fb50e4b83a64da3ebfbe94eafcb03ffc39b6ec1440112c7c1e98c9dfb020466dddecee074cf61fbcdacecae58982456bab99d6e1d771148bb6f111ec9db0900 SHA512 8e4ab9eb474413b22a6893bbcab01edd655bf354c263cfba339c37b2c14093ab22aac05d732576266fa3e98880b29473cf5ff29494c54e954215f58a5768409e
DIST monitoring-plugins-2.3.1.tar.gz 2529669 BLAKE2B 8dbbab78c1e57e249024fe57439acb41960585f2cccba20d03ca75a04b87e84752665f49cfe545c6a409d29094077dac0485aef872586f853e2f0f2187bf5070 SHA512 0ae76bc776997ed23d142ad9a688edc4df9b8ec0f9539b446e4fb4849a165cc88e97cbfb3a7a9a450de452e021d38f2e4ada7e8a22d78cf58e17e266472d01d7
DIST monitoring-plugins-2.3.2.tar.gz 2766966 BLAKE2B 1a9c35e8df22d5666005b4b79f5a7ee878c0d4be1e98039f341b198a658747010e8c9d1c0a1818d67a402e5c302ec5eb5073628d52c29caf41dbc2ce57c18f6c SHA512 d155f09ddd99f4e0d065627d3bf8768e13ae3f58ed25912f33b070cd24d6f3f43243616ec3e2d496dec633feee6b1f14950035a928034a1413f725814e850765
diff --git a/net-analyzer/monitoring-plugins/files/define-own-mysql-port-constant.patch b/net-analyzer/monitoring-plugins/files/define-own-mysql-port-constant.patch
deleted file mode 100644
index b7406bc9af80..000000000000
--- a/net-analyzer/monitoring-plugins/files/define-own-mysql-port-constant.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-From d6bd787123aa9ccd96edec8286ec22dd0442c620 Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Fri, 27 Oct 2017 07:58:43 -0400
-Subject: [PATCH 1/3] plugins/check_mysql*.c: define our own default MySQL
- port.
-
-The MYSQL_PORT constant used to be defined in mysql.h, and was used as
-the default port in the two plugins check_mysql and check_mysql_query.
-Now that mysql.h no longer defines that constant, our plugins fail to
-build against newer versions of MySQL and MariaDB.
-
-Since MYSQL_PORT used the "default port" on the local system, it
-actually was not the best choice as the default for the check plugins:
-when monitoring remote MySQL servers, the usual default of 3306 is
-more likely to be correct than whatever the local server happens to be
-listening on.
-
-As a result, we fix the issue by defining our own constant, called
-CHECK_PORT_DEFAULT, as "3306" at the top of both check_mysql.c and
-check_mysql_query.c. The existing uses of MYSQL_PORT have been changed
-to use the new CHECK_PORT_DEFAULT.
-
-This change is backwards-incompatible: any users who compiled in a
-MYSQL_PORT other than 3306 and who were running their checks on the
-same server as the database will now need to specify that port
-explicitly.
-
-Closes: https://github.com/monitoring-plugins/monitoring-plugins/issues/1508
----
- plugins/check_mysql.c | 8 ++++++--
- plugins/check_mysql_query.c | 8 ++++++--
- 2 files changed, 12 insertions(+), 4 deletions(-)
-
-diff --git a/plugins/check_mysql.c b/plugins/check_mysql.c
-index 5773afd9..c44919d0 100644
---- a/plugins/check_mysql.c
-+++ b/plugins/check_mysql.c
-@@ -36,6 +36,10 @@ const char *email = "devel@monitoring-plugins.org";
-
- #define SLAVERESULTSIZE 70
-
-+/* The default port that MySQL servers listen on. */
-+#define CHECK_PORT_DEFAULT 3306
-+
-+
- #include "common.h"
- #include "utils.h"
- #include "utils_base.h"
-@@ -58,7 +62,7 @@ char *ciphers = NULL;
- bool ssl = false;
- char *opt_file = NULL;
- char *opt_group = NULL;
--unsigned int db_port = MYSQL_PORT;
-+unsigned int db_port = CHECK_PORT_DEFAULT;
- int check_slave = 0, warn_sec = 0, crit_sec = 0;
- int ignore_auth = 0;
- int verbose = 0;
-@@ -505,7 +509,7 @@ void
- print_help (void)
- {
- char *myport;
-- xasprintf (&myport, "%d", MYSQL_PORT);
-+ xasprintf (&myport, "%d", CHECK_PORT_DEFAULT);
-
- print_revision (progname, NP_VERSION);
-
-diff --git a/plugins/check_mysql_query.c b/plugins/check_mysql_query.c
-index 49a14dd3..6f492442 100644
---- a/plugins/check_mysql_query.c
-+++ b/plugins/check_mysql_query.c
-@@ -33,6 +33,10 @@ const char *progname = "check_mysql_query";
- const char *copyright = "1999-2007";
- const char *email = "devel@monitoring-plugins.org";
-
-+/* The default port that MySQL servers listen on. */
-+#define CHECK_PORT_DEFAULT 3306
-+
-+
- #include "common.h"
- #include "utils.h"
- #include "utils_base.h"
-@@ -48,7 +52,7 @@ char *db_pass = NULL;
- char *db = NULL;
- char *opt_file = NULL;
- char *opt_group = NULL;
--unsigned int db_port = MYSQL_PORT;
-+unsigned int db_port = CHECK_PORT_DEFAULT;
-
- int process_arguments (int, char **);
- int validate_arguments (void);
-@@ -299,7 +303,7 @@ void
- print_help (void)
- {
- char *myport;
-- xasprintf (&myport, "%d", MYSQL_PORT);
-+ xasprintf (&myport, "%d", CHECK_PORT_DEFAULT);
-
- print_revision (progname, NP_VERSION);
-
---
-2.13.6
-
diff --git a/net-analyzer/nagstamon/Manifest b/net-analyzer/nagstamon/Manifest
index e111abab5f0f..365e14534a33 100644
--- a/net-analyzer/nagstamon/Manifest
+++ b/net-analyzer/nagstamon/Manifest
@@ -1,6 +1,4 @@
-AUX nagstamon-3.0-setup.patch 1139 BLAKE2B f399c6c600785629c7c90b1de396c17805882554f3d4d9e0932cbf0c8761496cccac57b068b7a7c161bcde11223db2ed4a0c5563a15267f13d3553147044ca0f SHA512 7ec4f621e1dc91cb941811aaacb6322fee8024d39dfa65e39b3a19631a3ef7c78d4fcd4d8df5630b76904e3c415290b35ac777c4d0e863ce83e15832d061ea4d
AUX nagstamon-3.10.1-setup.patch 974 BLAKE2B f74093c6e66129843ba7702602fda6f0b4004c02253405c1e48df0391aca898cafe9a3858c1d5bb4fb739bc80ec227fc05aaff5ee62f56dc104c99f7761b05ba SHA512 e5a65c40c5cda55fb3a118bc39cf8a35efa684cffc657838292c0fdad31bf965395965b6ff5e3b536bad52c28646b6a6f6274bb1e7551bc58c323f4215cc4b1e
-AUX nagstamon-3.4.1-unknown-version-id.patch 745 BLAKE2B 9e9f4619f98cfdea4a0f90fbf5d0b3c34c9e940449752110018a9b72a5817e0445f79cc30a9f720a390d40f09e0a28d491f692c6cd7515eb42f4035af54d483d SHA512 d4100c8f334309fd8711e2113c8e00d00fde124328e0ecd3c50762ff2be1b53b3832995922924170f7c695cdcfb48ba0100fda93a046ea802c56a4a917f77d43
AUX nagstamon-3.8-setup.patch 1190 BLAKE2B 39eec86dc7fcd69d0e6ef5c3b986e1e1c3096bed7e9e60eb1b7986bd83b9542805cd78a46813ba8af566243d4890565c5670c4fa41fc209f3e261a61bc5108aa SHA512 172a11999da5aaba979c800278a2524c9f3de269f7c3b2dd994ea0f658d48ab6891723ba1e03296cbdd4f979b2ca84b391a763bf19279f22588b570be677a3c5
DIST nagstamon-3.10.1.tar.gz 574520 BLAKE2B 104d082a610c26af47d61b911094c51e3981947e19ed026bc725e479382bcec2b3d36c36400c379c738c970e1cb36183859e1dd132e1fe78c30be3f20688287f SHA512 83da92cc0d5ceaf7abbf2f2e289a2e83cbcb3bb4239d12f594da7543942a3945cfae68cfa9ecc33aa619967d1d35e1b88d4bb76398364c2f9754174fdd62649c
DIST nagstamon-3.8.0.tar.gz 585689 BLAKE2B 8ab52762bac4797ded3834a94a382174855504b8e39224938f8f720a4aaaf4b3885fb487504ed09d973210b90f612852964bdcc87a6b2dc7c6b07bebfdeacffe SHA512 d34d1c52ddadbafcd583a5e61f7f305ffc8f722d8c007bbefeee6501475f01612e810154bc5815abe27e9c43e4e695a8ec189dcc5b2b487840d79f92eb3edc43
diff --git a/net-analyzer/nagstamon/files/nagstamon-3.0-setup.patch b/net-analyzer/nagstamon/files/nagstamon-3.0-setup.patch
deleted file mode 100644
index 26bb22fec4df..000000000000
--- a/net-analyzer/nagstamon/files/nagstamon-3.0-setup.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 267ced2..538c5bb 100644
---- a/setup.py
-+++ b/setup.py
-@@ -37,7 +37,7 @@ if OS not in ['Windows', 'Darwin']:
- NAME = NAME.lower()
- VERSION = AppInfo.VERSION.replace('-', '.') + '.' + DIST + DIST_VERSION
-
--NAGSTAMON_SCRIPT = 'nagstamon.py'
-+NAGSTAMON_SCRIPT = 'nagstamon'
-
- # workaround to get directory of Qt5 plugins to add missing 'mediaservice' folder needed for audio on OSX and Windows
- from PyQt5 import QtCore
-@@ -130,12 +130,7 @@ setup(name=NAME,
- packages=['Nagstamon',
- 'Nagstamon.QUI',
- 'Nagstamon.Servers',
-- 'Nagstamon.thirdparty',
-- 'Nagstamon.thirdparty.Xlib',
-- 'Nagstamon.thirdparty.Xlib.ext',
-- 'Nagstamon.thirdparty.Xlib.protocol',
-- 'Nagstamon.thirdparty.Xlib.support',
-- 'Nagstamon.thirdparty.Xlib.xobject'],
-+ 'Nagstamon.thirdparty',],
- package_dir={'Nagstamon': 'Nagstamon'},
- package_data={'Nagstamon': ['resources/*']},
- data_files=[('%s/share/man/man1' % sys.prefix, ['Nagstamon/resources/nagstamon.1.gz']),
diff --git a/net-analyzer/nagstamon/files/nagstamon-3.4.1-unknown-version-id.patch b/net-analyzer/nagstamon/files/nagstamon-3.4.1-unknown-version-id.patch
deleted file mode 100644
index a71d9d97e5b1..000000000000
--- a/net-analyzer/nagstamon/files/nagstamon-3.4.1-unknown-version-id.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fix for unknown VERSION_ID which is now a fatal error in python
-3.7. Backported from upstream 638c7c7a22156ca7e542725d32dbbc71f2f008a9
-
---- a/Nagstamon/Helpers.py.~1~ 2020-01-24 16:12:12.000000000 +0100
-+++ b/Nagstamon/Helpers.py 2020-08-29 07:39:26.999988228 +0200
-@@ -454,7 +454,7 @@
- for property in os_release_file.read_text().splitlines():
- key, value = property.split('=', 1)
- os_release_dict[key] = value.strip('"').strip("'")
-- return (os_release_dict['ID'], os_release_dict['VERSION_ID'], os_release_dict['NAME'])
-+ return (os_release_dict['ID'], os_release_dict.get('VERSION_ID', 'unknown'), os_release_dict['NAME'])
- else:
- return False
- else:
diff --git a/net-analyzer/openvas-scanner/Manifest b/net-analyzer/openvas-scanner/Manifest
index a38a53ef166e..a1218ebb47e3 100644
--- a/net-analyzer/openvas-scanner/Manifest
+++ b/net-analyzer/openvas-scanner/Manifest
@@ -1,16 +1,8 @@
-AUX gvm-feed-sync-20.8.1.sh 1071 BLAKE2B e80f8e4bd72d3dd92b1bb15bdfcf1b90b3f4f7b86005c7387d39a8abbe2ed182f3c513b8658310d2838befaa19d7c2c50b650948aa629429114db99c52446736 SHA512 9cbfe6c0f264ab821a82029f6f8274cdd09ddbc73e886e36d07f3a3727a1b9d739c7c1458fca98d2ac6b65ea05681d227fb2a27c475b190d76ba2c9f2d447fb5
-AUX gvm-feed-sync.cron 98 BLAKE2B d0af35e85c0c84e6d848de26fbf3f03e8a7473cea9d46c513fbb0d46f1664a516c334221773309d4f9682187a0f46a447320772d52c9826cc8525df26d0b2c38 SHA512 06526d33017c83c7342d9c356fb80e22f7a145bf8cae9bd49a7c74ae5854f7248b2b3609bc0f423b7a3babaad59a4b92ba14873f7f4e20e4cd5af7eb9c01c5d0
-AUX gvm-feed-sync.sh 1037 BLAKE2B 6ef8a375a06c0ce5a6181ee26eccdfaba09a5d935c56b98bed4435fdaee6b068f8cf87889789d4108361c6c2e83fa1979d533519c47f0d621f63423c43aa96a9 SHA512 a2abb96e268c8d7f74f61cc509730e4949894fe4225b22cb0f9d4fe2b215da70cc96c79405f59f3b05e290a45de2eeeb5d5ecf632cb23da80dd2102d4900b78a
AUX openvas-scanner-20.8.1-rpath-qa-fix.patch 350 BLAKE2B f4179757f30a43da6fbff329f776a8173c95848f749052429804a4680d26740c6727f918b23517b2dea68a08a55294c9455bbc437f4bb44d0f06dcd056dd82bd SHA512 f873bed2df048fb60dc21665817f99cea6fa1e377f0a7d5c5163831dddbebd2b0ca4e5c94f1ca22ab54f3079ebd230882fc8a269ead21550780aea81b9c01476
AUX openvas-scanner-7.0.1-disable-automagic-dep.patch 1100 BLAKE2B e5fe847c43636b883af91b34386a7d94bb1b088cddc3c95d8314c03dec25c1d071ed7562019abb5d31a75bb2c4fded63644552b411091889612ef6c5c1a837f4 SHA512 b6d678413ca2a4771dcd6833e19d754745f3a7530f227befdad745d30bf23862120cb18359c1088552db18fb13bf491ed4a47523f7326e628101c5ade4156c58
AUX openvas-scanner-7.0.1-fix-linking-with-lld.patch 1074 BLAKE2B de151d837cf188e398ff2c193e8df056377c2fbd2597b0a98991f38fc48802e323d6f617ceacaa82845ab385335a722416a30723878bfc700a45b44de779cc62 SHA512 7ed1bf3560a5c5cca0acc22845fdc370d677c773477f5006a3223225b63c2cf41709dcb883c38e152d97419733e62731598560a6b4aed2e4ab12a6cdb51446b7
AUX openvas.conf 29 BLAKE2B 0cb02f4b349d996b07ca19a531b64a35692ce5afb0d1fd4b58b6c80ccce3caf82055b396b23fa14f561eb9b732afba0fdfccade4c33c5e300fa1aca41b3995b7 SHA512 7ae3c5eff9a63a5eaadee5886c80baa46ff123695a55e92f21178421bd69322b4c1c06615fd81ea461b61da12ff0e03f523ea3110105a58e709900a0e2d4eebc
-AUX openvassd-daemon.conf 394 BLAKE2B 9dd55e29004d6d55f0cd44568b3b22aab21cb4ed88969934e5b1905cdfb05017843ee46f59297f8cba5d7b9db35a0b9c906d1f00075c4361d57e039d7d0cf601 SHA512 c8076ecaa04824e45d7b9b90e63c530d8bbcec6ca22b4ac4d3f2b661f05b8a684f6bef340f9f4524a311c19efa85013199f2de5088efe799969bde301ebe1e82
-AUX openvassd.gvm.conf 3577 BLAKE2B dd7452f0c9e63e431cf03553e221f802f7f7463ba36ad64fe18db12a44c3e7c0c4ded80cf4b7ab346a877e95271e5b10b7811d431be533eea2bb98eab53a9cee SHA512 dde7b0fe72e5dd551afdd3817562d785c95a03bbc109465490d65f81dc02a546e9d499a0c937828d2e38d357b9a7deadde12b2408307ea02a47c651c9fff4181
-AUX openvassd.init 480 BLAKE2B 28dfdabe7935ce55615fb36e6ddae3c36c84793ba01f6d3c92274a2fea1e44efe3f96bd3e7016740f4dcabff034173b541058d18f99081bd232a098a56d8e572 SHA512 1b0f13ab77f332708e9efb9cad06c47e61e47f68597c797e3f5140a921acaa2b856c10003938f737a20b534caaee7d3bb446d427373d8be8ef3fe7c83ee11b82
AUX openvassd.logrotate 330 BLAKE2B faf900a6882bb23c29859080d0c140c9dde8dcab42f31c31bfd43342beedab0bfe711f4e918aba5c7f8e5bb91430e251e270d0bc2e6f49e84ce98cdbbfe6d023 SHA512 397c9fd0d63ab66b463f65b6d235ec3e4e6ca52a3c811ddd4efcaeffc05fed8f9cd97605f439a628c144ecc1cfcfd31290d2a9dc6e57e8197d063b4aee63d73b
-AUX openvassd.service 472 BLAKE2B 528c25dbc32cd742753eb6b155a9221f0adde0e792b1e7af376b714831bcc210a228f5a87089f449f6f0e808f46f45d40fd68d9caed44530d57d99c37dbb8b0d SHA512 3497382e6540ddc341cf17e63f1c8d2250249bb51f8dbe379d48c1f90e81d00fdf03349a4dd08c6c6c2dc7336b385fa892b316ff2315a623952d8a2db33681bd
-AUX redis.conf.example 1351 BLAKE2B ad1a99404360b76144944793b2994554799bcc6624abce68524773b7f748075b8bcec79dcf94d2f400132a424a5147a3675d67f48d23a46e28a6afdca83e50a3 SHA512 b5024c26696f49e5d453cef7a0e3838a3fa557b2339a250f95d5367a30564b8a62733c86901ae000f62e916d73162188fbca1c56ed3a078dd99e8e8db1cc2c64
DIST openvas-scanner-21.4.4.tar.gz 460601 BLAKE2B 66d627e76912735539399aed637fdc07a7d13c9e4eb142498dcf181b8ea952dd93107bcc1f2ef577126178ff3dad1e5f6e50d67840692cd49f7352e3a726ce8f SHA512 f2fe1f802b14fc41ee0d7657d031d318b651c3ec9ef554b33379a7459d40c17b44525c8f666ccb9670868576c101766936dd0c700778e46683bf43f0683834b6
EBUILD openvas-scanner-21.4.4-r2.ebuild 2780 BLAKE2B ad007b59d5f9337adadfadff50648d67b741fcd35d14dcd731ab6b7301c7ac7141487081103c1f7a54d89a2d077eca2c94a391d4b95bae855d35c5975ec00164 SHA512 2f59c429409fd5eec2163c8eef9d0e97f8a5f555ae764fb51b3591e4630fa9462d6a393f28605453eea3b7c54736da01351f1ce67565787fabbbae74e136e251
MISC metadata.xml 955 BLAKE2B 89bbb8f84989c99ac00776d06921e3430e7865f1276139dbc87676a28133e157bca29f5c7bc077fc17ad6b8408d8aa2b967bf1a78569a516c83ff670698fccae SHA512 98c8d4c18d138b8bde6787394fe42fa4107205f8e6a262997c37e80364d7c0fea6caaeb331d3c918ac1a38f750273cf060360a5f7dd4a342cb834fc53d24d51f
diff --git a/net-analyzer/openvas-scanner/files/gvm-feed-sync-20.8.1.sh b/net-analyzer/openvas-scanner/files/gvm-feed-sync-20.8.1.sh
deleted file mode 100644
index 178f49eb0493..000000000000
--- a/net-analyzer/openvas-scanner/files/gvm-feed-sync-20.8.1.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/bin/sh
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-# GVM cron script that updates feed.
-
-# Start to update FEED & First NVT.
-try=0
-until [ $try -ge 5 ]; do
- greenbone-feed-sync --type GVMD_DATA --curl &>/dev/null && break
- try=$[$try+1]
- sleep 30
-done
-
-# Check status
-if [ $? -eq 0 ]; then
- # Avoid your IP temporary banned because of multiple connection
- sleep 5
- # Try to update scapdata.
- try=0
- until [ $try -ge 5 ]; do
- greenbone-feed-sync --type SCAP &>/dev/null && break
- try=$[$try+1]
- sleep 30
- done
-
- # Check status
- if [ $? -eq 0 ]; then
- # Avoid your IP temporary banned because of multiple connection
- sleep 5
- # Try to update certdata
- try=0
- until [ $try -ge 5 ]; do
- greenbone-feed-sync --type CERT &>/dev/null && break
- try=$[$try+1]
- sleep 30
- done
-
- # Check status
- if [ $? -eq 0 ]; then
- exit 0
- else
- exit 1
- fi
- fi
-fi
diff --git a/net-analyzer/openvas-scanner/files/gvm-feed-sync.cron b/net-analyzer/openvas-scanner/files/gvm-feed-sync.cron
deleted file mode 100644
index 5563b92929b1..000000000000
--- a/net-analyzer/openvas-scanner/files/gvm-feed-sync.cron
+++ /dev/null
@@ -1 +0,0 @@
-0 2 * * * gvm [ -x /etc/gvm/gvm-feed-sync.sh ] && /bin/bash /etc/gvm/gvm-feed-sync.sh > /dev/null
diff --git a/net-analyzer/openvas-scanner/files/gvm-feed-sync.sh b/net-analyzer/openvas-scanner/files/gvm-feed-sync.sh
deleted file mode 100644
index ba21632a4d6c..000000000000
--- a/net-analyzer/openvas-scanner/files/gvm-feed-sync.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/bin/sh
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-# GVM cron script that updates feed.
-
-# Start to update FEED & First NVT.
-try=0
-until [ $try -ge 5 ]; do
- greenbone-nvt-sync --curl &>/dev/null && break
- try=$[$try+1]
- sleep 30
-done
-
-# Check status
-if [ $? -eq 0 ]; then
- # Avoid your IP temporary banned because of multiple connection
- sleep 5
- # Try to update scapdata.
- try=0
- until [ $try -ge 5 ]; do
- greenbone-scapdata-sync &>/dev/null && break
- try=$[$try+1]
- sleep 30
- done
-
- # Check status
- if [ $? -eq 0 ]; then
- # Avoid your IP temporary banned because of multiple connection
- sleep 5
- # Try to update certdata
- try=0
- until [ $try -ge 5 ]; do
- greenbone-certdata-sync &>/dev/null && break
- try=$[$try+1]
- sleep 30
- done
-
- # Check status
- if [ $? -eq 0 ]; then
- exit 0
- else
- exit 1
- fi
- fi
-fi
diff --git a/net-analyzer/openvas-scanner/files/openvassd-daemon.conf b/net-analyzer/openvas-scanner/files/openvassd-daemon.conf
deleted file mode 100644
index 6bb70d165355..000000000000
--- a/net-analyzer/openvas-scanner/files/openvassd-daemon.conf
+++ /dev/null
@@ -1,17 +0,0 @@
-# OpenVAS Scanner command args
-
-# e.g --foreground
-OPENVAS_SCANNER_OPTIONS=""
-
-# Scanner listen socket
-OPENVAS_SCANNER_LISTEN_SOCKET="--unix-socket=/var/run/openvassd.sock"
-
-# Scanner listen owner
-OPENVAS_SCANNER_LISTEN_OWNER="--listen-owner=gvm"
-
-# Scanner listen group
-OPENVAS_SCANNER_LISTEN_GROUP="--listen-group=gvm"
-
-# Scanner listen mode
-OPENVAS_SCANNER_LISTEN_MODE="--listen-mode=755"
-
diff --git a/net-analyzer/openvas-scanner/files/openvassd.gvm.conf b/net-analyzer/openvas-scanner/files/openvassd.gvm.conf
deleted file mode 100644
index 5dfb8b527454..000000000000
--- a/net-analyzer/openvas-scanner/files/openvassd.gvm.conf
+++ /dev/null
@@ -1,124 +0,0 @@
-# You can get detailed informations from https://linux.die.net/man/8/openvassd
-# Configuration file of the OpenVAS Security Scanner
-# Every line starting with a '#' is a comment
-
-[Misc]
-
-# Path to the security checks folder:
-plugins_folder = /var/lib/openvas/plugins
-
-# Path to OpenVAS caching folder:
-cache_folder = /var/cache/openvas
-
-# Path to OpenVAS include directories:
-# (multiple entries are separated with colon ':')
-include_folders = /var/lib/openvas/plugins
-
-# Config File
-config_file = /etc/openvas/openvassd.conf
-
-# Maximum number of simultaneous hosts tested :
-max_hosts = 30
-
-# Maximum number of simultaneous checks against each host tested :
-max_checks = 10
-
-# Niceness. If set to 'yes', openvassd will renice itself to 10.
-be_nice = no
-
-# Log file (or 'syslog') :
-logfile = /var/log/gvm/openvassd.log
-
-# Shall we log every details of the attack ? (disk intensive)
-log_whole_attack = no
-
-# Log the name of the plugins that are loaded by the server ?
-log_plugins_name_at_load = no
-
-# Dump file for debugging output, use `-' for stdout
-dumpfile = /var/log/gvm/openvassd.dump
-
-# Rules file :
-rules = /etc/openvas/openvassd.rules
-
-# CGI paths to check for (cgi-bin:/cgi-aws:/ can do)
-cgi_path = /cgi-bin:/scripts
-
-# Range of the ports the port scanners will scan :
-# 'default' means that OpenVAS will scan ports found in its
-# services file.
-port_range = default
-
-# Optimize the test (recommended) :
-# Turn off for push hard but increase false positive and slow down scans
-optimize_test = yes
-
-# Optimization :
-# Read timeout for the sockets of the tests :
-checks_read_timeout = 5
-
-# Ports against which two plugins should not be run simultaneously :
-# non_simult_ports = Services/www, 139, Services/finger
-non_simult_ports = 139, 445
-
-# Maximum lifetime of a plugin (in seconds) :
-plugins_timeout = 320
-
-# Safe checks rely on banner grabbing & If enabled push harder to target:
-safe_checks = yes
-
-# Automatically activate the plugins that are depended on
-auto_enable_dependencies = yes
-
-# Do not echo data from plugins which have been automatically enabled
-silent_dependencies = no
-
-# Designate hosts by MAC address, not IP address (useful for DHCP networks)
-use_mac_addr = no
-
-
-#--- Knowledge base saving (can be configured by the client) :
-# Save the knowledge base on disk :
-save_knowledge_base = no
-
-# Restore the KB for each test :
-kb_restore = no
-
-# Only test hosts whose KB we do not have :
-only_test_hosts_whose_kb_we_dont_have = no
-
-# Only test hosts whose KB we already have :
-only_test_hosts_whose_kb_we_have = no
-
-# KB test replay :
-kb_dont_replay_scanners = no
-kb_dont_replay_info_gathering = no
-kb_dont_replay_attacks = no
-kb_dont_replay_denials = no
-kb_max_age = 864000
-#--- end of the KB section
-
-# Redis socket default setting
-db_address = /tmp/redis.sock
-
-# If this option is set, OpenVAS will not scan a network incrementally
-# (10.0.0.1, then 10.0.0.2, 10.0.0.3 and so on..) but will attempt to
-# slice the workload throughout the whole network (ie: it will scan
-# 10.0.0.1, then 10.0.0.127, then 10.0.0.2, then 10.0.0.128 and so on...
-slice_network_addresses = no
-
-# Should consider all the NASL scripts as being signed ? (unsafe if set to 'yes')
-nasl_no_signature_check = yes
-
-#Certificates
-cert_file=/var/lib/gvm/CA/servercert.pem
-key_file=/var/lib/gvm/private/CA/serverkey.pem
-ca_file=/var/lib/gvm/CA/cacert.pem
-
-# If you decide to protect your private key with a password,
-# uncomment and change next line
-# pem_password=password
-# If you want to force the use of a client certificate, uncomment next line
-# force_pubkey_auth = yes
-
-#end.
diff --git a/net-analyzer/openvas-scanner/files/openvassd.init b/net-analyzer/openvas-scanner/files/openvassd.init
deleted file mode 100644
index 9bd7332134fc..000000000000
--- a/net-analyzer/openvas-scanner/files/openvassd.init
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-name="Open Vulnerability Assessment Scanner"
-command="/usr/bin/openvassd"
-command_args="${OPENVAS_SCANNER_OPTIONS} ${OPENVAS_SCANNER_LISTEN_SOCKET} ${OPENVAS_SCANNER_LISTEN_OWNER} ${OPENVAS_SCANNER_LISTEN_GROUP} ${OPENVAS_SCANNER_LISTEN_MODE}"
-pidfile="/run/openvassd.pid"
-command_background="true"
-
-depend() {
- after bootmisc
- need localmount net redis
-}
diff --git a/net-analyzer/openvas-scanner/files/openvassd.service b/net-analyzer/openvas-scanner/files/openvassd.service
deleted file mode 100644
index b7d7df8bbab0..000000000000
--- a/net-analyzer/openvas-scanner/files/openvassd.service
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=Open Vulnerability Assessment Scanner
-After=network.target
-After=redis.service
-Before=gvmd.service
-Requires=redis.service
-
-[Service]
-Type=forking
-EnvironmentFile=-/etc/openvas/sysconfig/openvassd-daemon.conf
-ExecStart=/usr/bin/openvassd $OPENVAS_SCANNER_OPTIONS $OPENVAS_SCANNER_LISTEN_SOCKET $OPENVAS_SCANNER_LISTEN_OWNER $OPENVAS_SCANNER_LISTEN_GROUP $OPENVAS_SCANNER_LISTEN_MODE
-Restart=on-failure
-RestartSec=10
-
-[Install]
-WantedBy=multi-user.target
diff --git a/net-analyzer/openvas-scanner/files/redis.conf.example b/net-analyzer/openvas-scanner/files/redis.conf.example
deleted file mode 100644
index 6a41211aaae8..000000000000
--- a/net-analyzer/openvas-scanner/files/redis.conf.example
+++ /dev/null
@@ -1,57 +0,0 @@
-bind 127.0.0.1
-protected-mode yes
-port 0
-tcp-backlog 511
-unixsocket /tmp/redis.sock
-unixsocketperm 700
-timeout 0
-tcp-keepalive 300
-daemonize no
-supervised no
-pidfile /run/redis/redis.pid
-loglevel notice
-logfile /var/log/redis/redis.log
-databases 16
-always-show-logo yes
-stop-writes-on-bgsave-error yes
-rdbcompression yes
-rdbchecksum yes
-dbfilename dump.rdb
-dir /var/lib/redis/
-slave-serve-stale-data yes
-slave-read-only yes
-repl-diskless-sync no
-repl-diskless-sync-delay 5
-repl-disable-tcp-nodelay no
-slave-priority 100
-lazyfree-lazy-eviction no
-lazyfree-lazy-expire no
-lazyfree-lazy-server-del no
-slave-lazy-flush no
-appendonly no
-appendfilename "appendonly.aof"
-appendfsync everysec
-no-appendfsync-on-rewrite no
-auto-aof-rewrite-percentage 100
-auto-aof-rewrite-min-size 64mb
-aof-load-truncated yes
-aof-use-rdb-preamble no
-lua-time-limit 5000
-slowlog-log-slower-than 10000
-slowlog-max-len 128
-latency-monitor-threshold 0
-notify-keyspace-events ""
-hash-max-ziplist-entries 512
-hash-max-ziplist-value 64
-list-max-ziplist-size -2
-list-compress-depth 0
-set-max-intset-entries 512
-zset-max-ziplist-entries 128
-zset-max-ziplist-value 64
-hll-sparse-max-bytes 3000
-activerehashing yes
-client-output-buffer-limit normal 0 0 0
-client-output-buffer-limit slave 256mb 64mb 60
-client-output-buffer-limit pubsub 32mb 8mb 60
-hz 10
-aof-rewrite-incremental-fsync yes