summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin43276 -> 43274 bytes
-rw-r--r--net-analyzer/netdata/Manifest2
-rw-r--r--net-analyzer/netdata/netdata-1.46.0.ebuild163
-rw-r--r--net-analyzer/scanssh/Manifest3
-rw-r--r--net-analyzer/scanssh/files/scanssh-2.1.3-libdir.diff191
-rw-r--r--net-analyzer/scanssh/scanssh-2.1.3.1.ebuild50
6 files changed, 409 insertions, 0 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index b4972d406b24..3de9bb13fc37 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/netdata/Manifest b/net-analyzer/netdata/Manifest
index f2c45c90347e..2dcbcbae5166 100644
--- a/net-analyzer/netdata/Manifest
+++ b/net-analyzer/netdata/Manifest
@@ -1,4 +1,6 @@
DIST netdata-1.45.4.tar.gz 74881136 BLAKE2B e6184458a8b7e4430fb3e11543812f00652712c0c78d3ffb2f040adf649ceb4b01b4984165e489dfbea5c2207b702319fd5f3fb0d6d420e8973a20e54f3555b9 SHA512 44ab814c1dfb8c70880a363abbf29115189da366a49df953665dc2831da389e46ac2e33c288ebdbb10478f66180d0243d1b848a2f94043449198a87d9ad06340
+DIST netdata-1.46.0.tar.gz 75133626 BLAKE2B 3e98dc4ed5d964da3e676c1d9aecdce16cc88d59032e78235b78b9b85b73ac6b193bbb7b87e385eeb708df3e843b01cb0363eaeea9c5e99a82284d866a0928dd SHA512 f45277e94e998a8460560c9bda19908e0b06426a5b750960f481ca5ea93a2864a3408db5ba43cf7bddd8810eb9380c88353d6309c3e5a45bb8bc746eecdf604d
EBUILD netdata-1.45.4.ebuild 4335 BLAKE2B af56d57f7c289c67b44cc7ba47349e1c2d62cd1c8288b259f80d9325ac4c68b9f096f93f4c854fb3dc70b889361d07ec55ab90d7b35e7d74cf44e96b7da7a41b SHA512 001e9411d8fded3b47f7ef3e3904b5c78433a5cb894bd90c7723d541c889d8b6a13734322f19b97b184c3510d40db5bb2848344565780e9840f8e3e411d0b0d8
+EBUILD netdata-1.46.0.ebuild 4335 BLAKE2B af56d57f7c289c67b44cc7ba47349e1c2d62cd1c8288b259f80d9325ac4c68b9f096f93f4c854fb3dc70b889361d07ec55ab90d7b35e7d74cf44e96b7da7a41b SHA512 001e9411d8fded3b47f7ef3e3904b5c78433a5cb894bd90c7723d541c889d8b6a13734322f19b97b184c3510d40db5bb2848344565780e9840f8e3e411d0b0d8
EBUILD netdata-9999.ebuild 4335 BLAKE2B af56d57f7c289c67b44cc7ba47349e1c2d62cd1c8288b259f80d9325ac4c68b9f096f93f4c854fb3dc70b889361d07ec55ab90d7b35e7d74cf44e96b7da7a41b SHA512 001e9411d8fded3b47f7ef3e3904b5c78433a5cb894bd90c7723d541c889d8b6a13734322f19b97b184c3510d40db5bb2848344565780e9840f8e3e411d0b0d8
MISC metadata.xml 1357 BLAKE2B d7b8f45aaa7dc92cc61e5452f883069997f571d6461572430786f85783d3ed42a23f079818da95495eb3a613eb7107ab3509eddda317f728a0a21e5f8dad98a9 SHA512 ee5f106689c754cb4dc679eba1a00d69c0df858146b168f5a02faac794a8b21cfcadee316e9fbfa26433ed16eb3c56ddb8cdc70d950882be1aada7433795d2d0
diff --git a/net-analyzer/netdata/netdata-1.46.0.ebuild b/net-analyzer/netdata/netdata-1.46.0.ebuild
new file mode 100644
index 000000000000..725670699e12
--- /dev/null
+++ b/net-analyzer/netdata/netdata-1.46.0.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python{3_9,3_10,3_11,3_12} )
+
+inherit cmake fcaps flag-o-matic linux-info optfeature python-single-r1 systemd
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/netdata/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Linux real time system monitoring, done right!"
+HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
+
+LICENSE="GPL-3+ MIT BSD"
+SLOT="0"
+IUSE="aclk bpf cloud cups +dbengine ipmi mongodb mysql nfacct nodejs postgres prometheus +python systemd tor xen"
+REQUIRED_USE="
+ mysql? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tor? ( python )"
+
+# most unconditional dependencies are for plugins.d/charts.d.plugin:
+RDEPEND="
+ acct-group/netdata
+ acct-user/netdata
+ app-misc/jq
+ >=app-shells/bash-4:0
+ || (
+ net-analyzer/openbsd-netcat
+ net-analyzer/netcat
+ )
+ net-libs/libwebsockets
+ net-misc/curl
+ net-misc/wget
+ sys-apps/util-linux
+ app-alternatives/awk
+ sys-libs/libcap
+ cups? ( net-print/cups )
+ app-arch/lz4:=
+ app-arch/zstd:=
+ app-arch/brotli:=
+ dbengine? (
+ dev-libs/judy
+ dev-libs/openssl:=
+ )
+ dev-libs/libpcre2:=
+ dev-libs/libuv:=
+ dev-libs/libyaml
+ dev-libs/protobuf:=
+ bpf? ( virtual/libelf:= )
+ sys-libs/zlib
+ ipmi? ( sys-libs/freeipmi )
+ dev-libs/json-c:=
+ mongodb? ( dev-libs/mongo-c-driver )
+ nfacct? (
+ net-firewall/nfacct
+ net-libs/libmnl:=
+ )
+ nodejs? ( net-libs/nodejs )
+ prometheus? (
+ app-arch/snappy:=
+ dev-libs/protobuf:=
+ )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
+ mysql? ( $(python_gen_cond_dep 'dev-python/mysqlclient[${PYTHON_USEDEP}]') )
+ postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_USEDEP}]') )
+ tor? ( $(python_gen_cond_dep 'net-libs/stem[${PYTHON_USEDEP}]') )
+ )
+ xen? (
+ app-emulation/xen-tools
+ dev-libs/yajl
+ )
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+FILECAPS=(
+ 'cap_dac_read_search,cap_sys_ptrace+ep'
+ 'usr/libexec/netdata/plugins.d/apps.plugin'
+ 'usr/libexec/netdata/plugins.d/debugfs.plugin'
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/927174
+ # https://github.com/netdata/netdata/issues/17321
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
+ -DCMAKE_INSTALL_PREFIX=/
+ -DENABLE_ACLK=$(usex aclk)
+ -DENABLE_CLOUD=$(usex cloud)
+ -DENABLE_DBENGINE=$(usex dbengine)
+ -DENABLE_PLUGIN_CUPS=$(usex cups)
+ -DENABLE_PLUGIN_NFACCT=$(usex nfacct)
+ -DENABLE_PLUGIN_FREEIPMI=$(usex ipmi)
+ -DENABLE_EXPORTER_MONGODB=$(usex mongodb)
+ -DENABLE_EXPORTER_PROMETHEUS_REMOTE_WRITE=$(usex prometheus)
+ -DENABLE_PLUGIN_XENSTAT=$(usex xen)
+ -DENABLE_PLUGIN_EBPF=$(usex bpf)
+ -DENABLE_PLUGIN_GO=FALSE
+ -DENABLE_PLUGIN_SYSTEMD_JOURNAL=$(usex systemd)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ rm -rf "${D}/var/cache" || die
+ rm -rf "${D}/var/run" || die
+
+ keepdir /var/log/netdata
+ fowners -Rc netdata:netdata /var/log/netdata
+ keepdir /var/lib/netdata
+ keepdir /var/lib/netdata/registry
+ keepdir /var/lib/netdata/cloud.d
+ fowners -Rc netdata:netdata /var/lib/netdata
+
+ newinitd "${D}/usr/lib/netdata/system/openrc/init.d/netdata" "${PN}"
+ newconfd "${D}/usr/lib/netdata/system/openrc/conf.d/netdata" "${PN}"
+ systemd_newunit "${D}/usr/lib/netdata/system/systemd/netdata.service.v235" netdata.service
+ systemd_dounit "${D}/usr/lib/netdata/system/systemd/netdata-updater.service"
+ systemd_dounit "${D}/usr/lib/netdata/system/systemd/netdata-updater.timer"
+ insinto /etc/netdata
+ doins system/netdata.conf
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if use nfacct ; then
+ fcaps 'cap_net_admin' 'usr/libexec/netdata/plugins.d/nfacct.plugin'
+ fi
+
+ if use xen ; then
+ fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/xenstat.plugin'
+ fi
+
+ if use ipmi ; then
+ fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/freeipmi.plugin'
+ fi
+
+ optfeature "go.d external plugin" net-analyzer/netdata-go-plugin
+}
diff --git a/net-analyzer/scanssh/Manifest b/net-analyzer/scanssh/Manifest
index 914195f67d52..b19efa27daf7 100644
--- a/net-analyzer/scanssh/Manifest
+++ b/net-analyzer/scanssh/Manifest
@@ -1,5 +1,8 @@
AUX scanssh-2.0-fix-warnings.diff 1071 BLAKE2B c92997cd26cd03ec451ebf83a54f19ba86d6b33f90dd666c8637fceb222849b3d2703ca9c8c1645a95186059ccf049ae462d7a4c58486ee8c0d086cb8f73e625 SHA512 b9080dbe7551e905db0744ca36b8690d05d784ad7c4c77f4fcbe64ff603353e998cc28ae45c26e230f594278cdb6f130029aa633166e6636933be44845c27b06
AUX scanssh-2.0-libdir.diff 4916 BLAKE2B 23fb00f8880e9a2407e919c626328430fc7c09d21bcdb535cf2411b41fc4c623ab04e2411dbdd239e62cc4f6545b9d67d29bab879f6ac268c241d1cd884b2592 SHA512 be01518f156b724439837150f9f02148d6f92c0bac2557419f2f9def9244d29006a6c84ceecf193b6f57830c697d9b650102625cf78787fc59709a2ef2b7847f
+AUX scanssh-2.1.3-libdir.diff 5254 BLAKE2B d1f52730480f97c2518ccdf0c125d7d376a91bb32de5510c92e81cd4ce19bec9f1c65a568bc3e7f490b61ce31ac5349b518d8011411f86d33a43b4feef9f893e SHA512 b8668f2b89e1861ac5dd782da0927d9c6fd3d51b1ccef7bff42b061fd37b91d7515b42a26fcda4aeae64d95b9cf447763d343df701df879758bf1098d6451f55
DIST scanssh-2.1.2.tar.gz 147470 BLAKE2B 4cb31a27dd925f071bcb958fc72bef7b7f0455b7d718a15536dae40cee969739628da64a3972e2c5cc9813ef24c5634ca019571783ea20df87c7df80f32da876 SHA512 af4e705c43156b907d6864b12f5832bb4e43d0ff284e34e96b32bbe7986299954d1175880ffe7588f91a939d140b45592fc72dc2bf397f140aed929dbe44a453
+DIST scanssh-2.1.3.1.tar.gz 147954 BLAKE2B a263eda2d49159e715bb8d2190fc78f8e41d5f3a56e0bf67b70ed716eb787c09cff0ea9e759b5aa62096f75de01d2d5b5980aa66a7c5b14635d835fd3b7c6f07 SHA512 970cbb03aa44fcef62aa03132335e6ecedb083cee98a360b3d781efc8c2d3c169f70c17837b1faaf9ceaa2691a7c619174a9bb185146af50188eaceda5d14adb
EBUILD scanssh-2.1.2.ebuild 860 BLAKE2B 0d8ba021d32cf1656aa6823c96e716f3120ee3406de26bd78f827d13257c88a9acf54865c1b191a65c89c194bffd1e3dc34de664eb2f17bfe0bee9c9dbb31135 SHA512 acfa6e2a2f041773d15d8894ce95c2be194f100c9276f47081b5ad371299190620813f20c989ce065de6eb6950e1478ea5df35a607c81f86b8d43246869273d9
+EBUILD scanssh-2.1.3.1.ebuild 865 BLAKE2B 492a8889780f0189563830199fb0dad9a80e9af22272845c3a7cea0cf308c0673cef45e69f2f883f2b5b451e821c8e2b3a425a1325174e52a6c572a4e39aac37 SHA512 678116483f524b7996107ee5c59cae64a9d17a821c711277b7af6eee68c7a3dedd25e977f569da5ae215b607e568e2cae7328a69cd7329db2ebee427c01b8d34
MISC metadata.xml 512 BLAKE2B 58be7a766b9858f55a5d2926ed85a19545014f3a6f522132f03b11c2ae0b0f050e8cb85abc09725b4bcc6cb8f87ce50792756e31e8bf523d6da1ac4f1c012854 SHA512 d5c347f2a04abb0a6ba81edc8df0c844cab63d2eab85eaa01d8e847b4bde02ff4bb1e4531fa18678d66f032d4078ad17dce34b3b0aa27e9e0f964a77e829c6f5
diff --git a/net-analyzer/scanssh/files/scanssh-2.1.3-libdir.diff b/net-analyzer/scanssh/files/scanssh-2.1.3-libdir.diff
new file mode 100644
index 000000000000..c34159b3fca7
--- /dev/null
+++ b/net-analyzer/scanssh/files/scanssh-2.1.3-libdir.diff
@@ -0,0 +1,191 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,8 +20,8 @@ AC_PROG_CC
+ AC_PROG_INSTALL
+
+ dnl XXX - Solaris sux.
+-AC_CHECK_LIB(socket, socket)
+-AC_CHECK_LIB(nsl, gethostbyname)
++AC_SEARCH_LIBS(socket, socket)
++AC_SEARCH_LIBS(gethostbyname, nsl)
+
+ dnl XXX - we need WinPcap developer's pack under Cygwin for win32
+
+@@ -33,11 +33,11 @@ case $host_os in
+ if test -d /usr/include/mingw ; then
+ CPPFLAGS="$CPPFLAGS -mno-cygwin"
+ CFLAGS="$CFLAGS -mno-cygwin"
+- AC_DEFINE(WIN32_LEAN_AND_MEAN, 1,
++ AC_DEFINE(WIN32_LEAN_AND_MEAN, 1,
+ [Define for faster code generation.])
+ AC_CHECK_LIB(ws2_32, main)
+ AC_CHECK_LIB(iphlpapi, main)
+- AC_DEFINE(snprintf, _snprintf,
++ AC_DEFINE(snprintf, _snprintf,
+ [Use MingW32's internal snprintf])
+ else
+ AC_MSG_ERROR([need MingW32 package to build under Cygwin])
+@@ -84,92 +84,9 @@ if test $neederr = yes; then
+ AC_LIBOBJ(err)
+ fi
+
+-dnl Checks for libpcap
+-AC_MSG_CHECKING(for libpcap)
+-AC_ARG_WITH(libpcap,
+-[ --with-libpcap=DIR use libpcap build directory],
+-[ case "$withval" in
+- yes|no)
+- AC_MSG_RESULT(no)
+- ;;
+- *)
+- AC_MSG_RESULT($withval)
+- if test -f $withval/pcap.h -a -f $withval/libpcap.a; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- PCAPINC="-I$withval -I$withval/bpf"
+- PCAPLIB="-L$withval -lpcap"
+- else
+- AC_MSG_ERROR(pcap.h or libpcap.a not found in $withval)
+- fi
+- ;;
+- esac ],
+-[ if test -f ${prefix}/include/pcap.h; then
+- PCAPINC="-I${prefix}/include"
+- PCAPLIB="-L${prefix}/lib -lpcap"
+- elif test -f /usr/include/pcap/pcap.h; then
+- PCAPINC="-I/usr/include/pcap"
+- PCAPLIB="-lpcap"
+- elif test -f /usr/include/pcap.h; then
+- PCAPLIB="-lpcap"
+- else
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(libpcap not found)
+- fi
+- AC_MSG_RESULT(yes) ]
+-)
+ AC_SUBST(PCAPINC)
+ AC_SUBST(PCAPLIB)
+
+-dnl Checks for (installed) libdnet
+-AC_ARG_WITH(libdnet,
+-[ --with-libdnet=DIR use libdnet in DIR],
+-[ case "$withval" in
+- yes|no)
+- AC_MSG_ERROR(Please specify directory containing dnet-config when using --with-libdnet)
+- ;;
+- *)
+- AC_MSG_CHECKING(for libdnet)
+- AC_MSG_RESULT($withval)
+- if test -f $withval/src/libdnet.a; then
+- DNETINC="-I$withval/include"
+- DNETLIB="-L$withval/src -ldnet `$withval/dnet-config --libs`"
+- elif test -x $withval/bin/dnet-config; then
+- DNETINC="`$withval/bin/dnet-config --cflags`"
+- DNETLIB="`$withval/bin/dnet-config --libs`"
+- else
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(dnet-config not found in $withval/bin)
+- fi
+- ;;
+- esac
+- AC_MSG_RESULT(yes) ],
+-[ dnl This is the default case so let's just use AC_PATH_PROG! --CPK.
+- AC_PATH_PROG(dnetconfig, dnet-config, "no")
+- if test "$dnetconfig" = "no"; then
+- AC_MSG_ERROR(dnet-config not found)
+- else
+- DNETINC="`$dnetconfig --cflags`"
+- DNETLIB="`$dnetconfig --libs`"
+- fi]
+-)
+-
+-dnl We still need to check whether it's dnet or dumbnet as
+-dnl for example on Debian. We test by looking at the content
+-dnl of DNETLIB and derive from the library name what version
+-dnl we're dealing with. If we find a libdumbnet, we prefix
+-dnl compat/libdnet to our inclusion path. It provides a dnet.h
+-dnl that transparently includes dumbnet.h for those systems. --CPK.
+-AC_MSG_CHECKING([whether libdnet is a libdumbnet])
+-if test `echo $DNETLIB | sed -e '/dumb/=;d'`; then
+- AC_MSG_RESULT(yes)
+- AC_DEFINE(HAVE_DUMBNET, 1,
+- [Define if our libdnet is a libdumbnet])
+- DNETCOMPAT="compat/libdnet"
+-else
+- AC_MSG_RESULT(no)
+-fi
+-
+ AC_SUBST(DNETCOMPAT)
+ AC_SUBST(DNETINC)
+ AC_SUBST(DNETLIB)
+@@ -180,50 +97,16 @@ then
+ else
+ CFLAGS="-I$DNETCOMPAT $DNETINC"
+ fi
++save_LIBS=$LIBS
+ LIBS=$DNETLIB
+
+-dnl Checks for libevent
+-AC_MSG_CHECKING(for libevent)
+-AC_ARG_WITH(libevent,
+-[ --with-libevent=DIR use libevent build directory],
+-[ case "$withval" in
+- yes|no)
+- AC_MSG_RESULT(no)
+- ;;
+- *)
+- AC_MSG_RESULT($withval)
+- if test -f $withval/event.h -a -f $withval/libevent.a; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- EVENTINC="-I$withval"
+- EVENTLIB="-L$withval -levent"
+- else
+- AC_MSG_ERROR(event.h or libevent.a not found in $withval)
+- fi
+- ;;
+- esac ],
+-[ if test -f ${prefix}/include/event.h; then
+- EVENTINC="-I${prefix}/include"
+- EVENTLIB="-L${prefix}/lib -levent"
+- elif test -f /usr/include/event/event.h; then
+- EVENTINC="-I/usr/include/event"
+- EVENTLIB="-levent"
+- elif test -f /usr/include/event.h; then
+- EVENTLIB="-levent"
+- else
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(libevent not found)
+- fi
+- AC_MSG_RESULT(yes) ]
+-)
+ AC_SUBST(EVENTINC)
+ AC_SUBST(EVENTLIB)
+
+ CFLAGS=$EVENTINC
+ LIBS=$EVENTLIB
+
+-CFLAGS=""
+-LIBS=""
++LIBS=$save_LIBS
+
+ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h)
+@@ -271,7 +154,7 @@ AC_EGREP_CPP(yes,
+ #ifdef BSD4_4
+ yes
+ #endif
+-],
++],
+ AC_EGREP_CPP(yes,
+ [#include <sys/param.h>
+ #ifdef OpenBSD
+@@ -285,7 +168,7 @@ AC_EGREP_CPP(yes,
+ ),
+ AC_MSG_RESULT([good byte order])
+ )
+-
++
+ AC_MSG_CHECKING([for sin_len in struct sockaddr_in])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <sys/types.h>
diff --git a/net-analyzer/scanssh/scanssh-2.1.3.1.ebuild b/net-analyzer/scanssh/scanssh-2.1.3.1.ebuild
new file mode 100644
index 000000000000..f19ad9605894
--- /dev/null
+++ b/net-analyzer/scanssh/scanssh-2.1.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="network scanner that gathers info on SSH protocols and versions"
+HOMEPAGE="https://github.com/ofalk/scanssh/"
+SRC_URI="https://github.com/ofalk/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ dev-libs/libdnet
+ dev-libs/libevent:=
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-fix-warnings.diff
+ "${FILESDIR}"/${PN}-2.1.3-libdir.diff
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ DNETINC='' \
+ DNETLIB=-ldnet \
+ EVENTINC='' \
+ EVENTLIB=-levent \
+ PCAPINC='' \
+ PCAPLIB=-lpcap
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin scanssh
+ doman scanssh.1
+}