summaryrefslogtreecommitdiff
path: root/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild')
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
index 40d10b23dee7..c94739cfae13 100644
--- a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit webapp java-pkg-opt-2 systemd toolchain-funcs go-module user-info
+inherit webapp java-pkg-opt-2 systemd tmpfiles toolchain-funcs go-module user-info
EGO_SUM=(
"github.com/BurntSushi/toml v0.3.1/go.mod h1:xHWCNGjB5oqiDr8zfno3MHue2Ht5sIBksp03qcyfWMU="
"github.com/cockroachdb/apd v1.1.0 h1:3LFP3629v+1aKXU5Q37mxmRxX/pIu1nijXydLShEq5I="
@@ -246,11 +246,12 @@ SRC_URI="https://cdn.zabbix.com/${PN}/sources/stable/$(ver_cut 1-2)/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
-KEYWORDS="~amd64 ~x86"
-IUSE="+agent +agent2 java curl frontend ipv6 ldap libxml2 mysql openipmi oracle +postgres proxy server ssh ssl snmp sqlite odbc static"
+KEYWORDS="amd64 x86"
+IUSE="+agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
- proxy? ( ^^ ( mysql oracle postgres sqlite odbc ) )
- server? ( ^^ ( mysql oracle postgres odbc ) )
+ proxy? ( ^^ ( mysql oracle postgres sqlite ) )
+ server? ( ^^ ( mysql oracle postgres ) )
+ ssl? ( ^^ ( gnutls openssl ) )
static? ( !oracle !snmp )"
COMMON_DEPEND="
@@ -275,7 +276,10 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
"
RDEPEND="${COMMON_DEPEND}
@@ -322,6 +326,9 @@ BDEPEND="
virtual/pkgconfig
"
+# upstream tests fail for agent2
+RESTRICT="test"
+
PATCHES=(
"${FILESDIR}/${PN}-4.0.18-modulepathfix.patch"
"${FILESDIR}/${PN}-3.0.30-security-disable-PidFile.patch"
@@ -370,17 +377,18 @@ src_configure() {
$(use_enable server) \
$(use_enable static) \
$(use_with curl libcurl) \
+ $(use_with gnutls) \
$(use_with ldap) \
$(use_with libxml2) \
$(use_with mysql) \
$(use_with odbc unixodbc) \
$(use_with openipmi openipmi) \
+ $(use_with openssl) \
$(use_with oracle) \
$(use_with postgres postgresql) \
$(use_with snmp net-snmp) \
$(use_with sqlite sqlite3) \
- $(use_with ssh ssh2) \
- $(use_with ssl openssl)
+ $(use_with ssh ssh2)
}
src_compile() {
@@ -419,7 +427,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-server.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+ newtmpfiles "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
fi
if use proxy; then
@@ -436,7 +444,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-proxy.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+ newtmpfiles "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
fi
if use agent; then
@@ -453,7 +461,7 @@ src_install() {
src/zabbix_get/zabbix_get
systemd_dounit "${FILESDIR}"/zabbix-agentd.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
fi
if use agent2; then
@@ -467,7 +475,7 @@ src_install() {
dosbin src/go/bin/zabbix_agent2
systemd_dounit "${FILESDIR}"/zabbix-agent2.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
fi
fowners root:zabbix /etc/zabbix