summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-99999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/wireshark-99999999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 6f9470ca6ee5..86206f1ead23 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -17,7 +17,7 @@ IUSE="
+dumpcap +editcap http2 kerberos libxml2 lua lz4 maxminddb +mergecap
+minizip +netlink +plugins plugin-ifdemo +pcap +qt5 +randpkt +randpktdump
+reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
- +text2pcap tfshark +tshark +udpdump zlib
+ test +text2pcap tfshark +tshark +udpdump zlib
"
S=${WORKDIR}/${P/_/}
@@ -73,6 +73,10 @@ BDEPEND="
qt5? (
dev-qt/linguist-tools:5
)
+ test? (
+ dev-python/pytest
+ dev-python/pytest-xdist
+ )
"
RDEPEND="
${CDEPEND}
@@ -168,6 +172,7 @@ src_configure() {
}
src_test() {
+ cmake_build test-programs
cmake_src_test
}