summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-2.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/wireshark-2.6.1.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-2.6.1.ebuild41
1 files changed, 17 insertions, 24 deletions
diff --git a/net-analyzer/wireshark/wireshark-2.6.1.ebuild b/net-analyzer/wireshark/wireshark-2.6.1.ebuild
index b9152684e6ed..efde4f468e86 100644
--- a/net-analyzer/wireshark/wireshark-2.6.1.ebuild
+++ b/net-analyzer/wireshark/wireshark-2.6.1.ebuild
@@ -176,31 +176,24 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README* doc/randpkt.txt doc/README*
# install headers
- local wsheader
- for wsheader in \
- epan/*.h \
- epan/crypt/*.h \
- epan/dfilter/*.h \
- epan/dissectors/*.h \
- epan/ftypes/*.h \
- epan/wmem/*.h \
- wiretap/*.h \
- ws_diag_control.h \
- ws_symbol_export.h \
- wsutil/*.h
- do
- echo "Installing ${wsheader}"
- insinto /usr/include/wireshark/$( dirname ${wsheader} )
- doins ${wsheader}
- done
-
- for wsheader in \
- ../${P}_build/config.h \
- ../${P}_build/version.h
+ insinto /usr/include/wireshark
+ doins ws_diag_control.h ws_symbol_export.h \
+ "${BUILD_DIR}"/config.h "${BUILD_DIR}"/version.h
+
+ local dir dirs=(
+ epan
+ epan/crypt
+ epan/dfilter
+ epan/dissectors
+ epan/ftypes
+ epan/wmem
+ wiretap
+ wsutil
+ )
+ for dir in "${dirs[@]}"
do
- echo "Installing ${wsheader}"
- insinto /usr/include/wireshark
- doins ${wsheader}
+ insinto /usr/include/wireshark/${dir}
+ doins ${dir}/*.h
done
#with the above this really shouldn't be needed, but things may be looking