summaryrefslogtreecommitdiff
path: root/net-analyzer/wapiti/wapiti-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wapiti/wapiti-9999.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-analyzer/wapiti/wapiti-9999.ebuild b/net-analyzer/wapiti/wapiti-9999.ebuild
index 1f375f8034b2..53d40bbaa97b 100644
--- a/net-analyzer/wapiti/wapiti-9999.ebuild
+++ b/net-analyzer/wapiti/wapiti-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE='xml'
inherit distutils-r1 git-r3
@@ -27,10 +27,14 @@ RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
-distutils_enable_tests pytest
+distutils_enable_tests --install pytest
BDEPEND+=" test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+# Many tests require execution of local test php server
+RESTRICT="test"
python_prepare_all() {
- sed -e 's/"pytest-runner"//' -i setup.py || die
+ sed -e 's/"pytest-runner"//' \
+ -e "/find_packages/s/()/(exclude=['tests*'])/" \
+ -i setup.py || die
distutils-r1_python_prepare_all
}