summaryrefslogtreecommitdiff
path: root/net-analyzer/vnstat/vnstat-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/vnstat/vnstat-9999.ebuild')
-rw-r--r--net-analyzer/vnstat/vnstat-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/net-analyzer/vnstat/vnstat-9999.ebuild b/net-analyzer/vnstat/vnstat-9999.ebuild
index 2db2af4d81b3..9ba136577512 100644
--- a/net-analyzer/vnstat/vnstat-9999.ebuild
+++ b/net-analyzer/vnstat/vnstat-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,12 +15,14 @@ else
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/teemutoivola.asc
inherit verify-sig
- SRC_URI="https://humdi.net/vnstat/${P}.tar.gz"
- SRC_URI+=" https://github.com/vergoh/vnstat/releases/download/v${PV}/${P}.tar.gz"
- SRC_URI+=" verify-sig? (
+ SRC_URI="
+ https://humdi.net/vnstat/${P}.tar.gz
+ https://github.com/vergoh/vnstat/releases/download/v${PV}/${P}.tar.gz
+ verify-sig? (
https://humdi.net/vnstat/${P}.tar.gz.asc
https://github.com/vergoh/vnstat/releases/download/v${PV}/${P}.tar.gz.asc
- )"
+ )
+ "
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
@@ -52,7 +54,7 @@ src_compile() {
emake \
${PN} \
${PN}d \
- $(usex gd ${PN}i '')
+ $(usev gd ${PN}i)
}
src_install() {