summaryrefslogtreecommitdiff
path: root/net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild')
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild
deleted file mode 100644
index d4aee56ff488..000000000000
--- a/net-analyzer/thc-ipv6/thc-ipv6-3.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
-EGIT_BRANCH=master
-
-inherit eutils toolchain-funcs ${SCM}
-
-DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
-HOMEPAGE="https://www.thc.org/thc-ipv6/"
-LICENSE="AGPL-3 openssl"
-SLOT="0"
-IUSE="ssl"
-
-if [[ ${PV} != *9999 ]]; then
- SRC_URI="http://www.thc.org/releases/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DEPEND="net-libs/libpcap
- net-libs/libnetfilter_queue
- ssl? ( dev-libs/openssl:* )"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-3.2-stdint.patch"
- "${FILESDIR}"/${PN}-3.0-Makefile.patch )
-
-src_unpack() {
- if [[ ${PV} != *9999 ]]; then
- default_src_unpack
- else
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- sed -e '/^CFLAGS=/s,CFLAGS=,CFLAGS?=,' \
- -i Makefile || die
- if ! use ssl ; then
- sed -e '/^HAVE_SSL/s:^:#:' \
- -i Makefile
- fi
- default
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" STRIP="true" install
- dodoc CHANGES HOWTO-INJECT README
-}