summaryrefslogtreecommitdiff
path: root/net-analyzer/sshping/sshping-0.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sshping/sshping-0.1.4.ebuild')
-rw-r--r--net-analyzer/sshping/sshping-0.1.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/sshping/sshping-0.1.4.ebuild b/net-analyzer/sshping/sshping-0.1.4.ebuild
new file mode 100644
index 000000000000..b6898c56a36b
--- /dev/null
+++ b/net-analyzer/sshping/sshping-0.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ssh-based ping: measure character echo latency and bandwidth"
+HOMEPAGE="https://github.com/spook/sshping"
+SRC_URI="https://github.com/spook/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-lang/perl"
+DEPEND="net-libs/libssh:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-man-dir.patch"
+ "${FILESDIR}/${P}-respect-cxxflags.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
+ )
+
+ cmake_src_configure
+}