summaryrefslogtreecommitdiff
path: root/net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild')
-rw-r--r--net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild b/net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..2a7c8b1f1b68
--- /dev/null
+++ b/net-analyzer/speedtest-cli/speedtest-cli-2.1.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command line interface for testing internet bandwidth using speedtest.net"
+HOMEPAGE="https://github.com/sivel/speedtest-cli"
+SRC_URI="https://github.com/sivel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ doman ${PN}.1
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn "net-analyzer/speedtest-cli is often times inaccurate, especially on faster"
+ ewarn "links, due to its use of the older HTTP-based API. In order to have more"
+ ewarn "accurate measurements, please use net-analyzer/speedtest++ instead."
+}