summaryrefslogtreecommitdiff
path: root/net-analyzer/speedtest++/speedtest++-0.0.20210829.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/speedtest++/speedtest++-0.0.20210829.ebuild')
-rw-r--r--net-analyzer/speedtest++/speedtest++-0.0.20210829.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/speedtest++/speedtest++-0.0.20210829.ebuild b/net-analyzer/speedtest++/speedtest++-0.0.20210829.ebuild
new file mode 100644
index 000000000000..4ccc533381c7
--- /dev/null
+++ b/net-analyzer/speedtest++/speedtest++-0.0.20210829.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="High performance speedtest.net CLI"
+HOMEPAGE="https://github.com/taganaka/SpeedTest"
+SNAPSHOT_COMMIT="0f63cfbf7ce8d64ea803bf143b957eae76323405"
+SRC_URI="https://github.com/taganaka/SpeedTest/archive/${SNAPSHOT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/libxml2:=
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/SpeedTest-${SNAPSHOT_COMMIT}"