summaryrefslogtreecommitdiff
path: root/net-analyzer/sngrep/sngrep-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sngrep/sngrep-1.5.0.ebuild')
-rw-r--r--net-analyzer/sngrep/sngrep-1.5.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-analyzer/sngrep/sngrep-1.5.0.ebuild b/net-analyzer/sngrep/sngrep-1.5.0.ebuild
deleted file mode 100644
index af7e30fcebf6..000000000000
--- a/net-analyzer/sngrep/sngrep-1.5.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="Ncurses SIP Messages flow viewer"
-HOMEPAGE="https://github.com/irontec/sngrep"
-SRC_URI="https://github.com/irontec/sngrep/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="eep gnutls pcre ssl unicode"
-
-# In next release, libpcre -> libpcre2
-DEPEND="
- net-libs/libpcap
- sys-libs/ncurses:=[unicode(+)?]
- ssl? (
- !gnutls? ( dev-libs/openssl:= )
- gnutls? ( net-libs/gnutls:= )
- )
- pcre? ( dev-libs/libpcre )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0-bashisms.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-ipv6
-
- $(use_enable eep)
- $(use_enable unicode)
- $(use_with pcre)
- $(use_with ssl $(usex gnutls gnutls openssl))
- )
-
- econf "${myeconfargs[@]}"
-}