summaryrefslogtreecommitdiff
path: root/net-analyzer/sngrep/sngrep-1.4.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sngrep/sngrep-1.4.7.ebuild')
-rw-r--r--net-analyzer/sngrep/sngrep-1.4.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/sngrep/sngrep-1.4.7.ebuild b/net-analyzer/sngrep/sngrep-1.4.7.ebuild
new file mode 100644
index 000000000000..f021e73049e6
--- /dev/null
+++ b/net-analyzer/sngrep/sngrep-1.4.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Ncurses SIP Messages flow viewer"
+HOMEPAGE="https://github.com/irontec/sngrep"
+SRC_URI="https://github.com/irontec/sngrep/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eep gnutls ipv6 openssl pcre unicode"
+REQUIRED_USE="
+ gnutls? ( !openssl )
+"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=[unicode?]
+ openssl? ( dev-libs/openssl:0= )
+ gnutls? ( net-libs/gnutls )
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.7-tinfo.patch
+ "${FILESDIR}"/${PN}-1.4.7-LDFLAGS.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable eep) \
+ $(use_enable ipv6) \
+ $(use_enable unicode) \
+ $(use_with gnutls) \
+ $(use_with openssl) \
+ $(use_with pcre)
+}