summaryrefslogtreecommitdiff
path: root/net-analyzer/shodan/shodan-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/shodan/shodan-9999.ebuild')
-rw-r--r--net-analyzer/shodan/shodan-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-analyzer/shodan/shodan-9999.ebuild b/net-analyzer/shodan/shodan-9999.ebuild
index 984c33c3f1f6..c530e8f47fb4 100644
--- a/net-analyzer/shodan/shodan-9999.ebuild
+++ b/net-analyzer/shodan/shodan-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
DESCRIPTION="The official Python library for Shodan"
@@ -16,9 +16,8 @@ if [[ ${PV} = "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
else
- SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV}"
- KEYWORDS="~amd64 ~x86"
+ inherit pypi
+ KEYWORDS="~amd64 ~loong ~x86"
fi
LICENSE="MIT"
@@ -29,6 +28,7 @@ RDEPEND="
dev-python/click-plugins[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
dev-python/xlsxwriter[${PYTHON_USEDEP}]
"