summaryrefslogtreecommitdiff
path: root/net-analyzer/sarg/sarg-2.4.0_pre3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sarg/sarg-2.4.0_pre3.ebuild')
-rw-r--r--net-analyzer/sarg/sarg-2.4.0_pre3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/sarg/sarg-2.4.0_pre3.ebuild b/net-analyzer/sarg/sarg-2.4.0_pre3.ebuild
new file mode 100644
index 000000000000..992488f78a3c
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.4.0_pre3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="https://sourceforge.net/projects/sarg/"
+SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="bzip2 doublecheck +gd +glob ldap lzma pcre zlib"
+
+RDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ gd? ( media-libs/gd[png,truetype] )
+ ldap? ( net-nds/openldap )
+ lzma? ( app-arch/xz-utils )
+ pcre? ( dev-libs/libpcre )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.0-config.patch
+ "${FILESDIR}"/${PN}-2.4.0-configure.patch
+ "${FILESDIR}"/${PN}-2.4.0-fabs.patch
+ "${FILESDIR}"/${PN}-2.4.0-format.patch
+)
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doublecheck) \
+ $(use_with bzip2 bzlib) \
+ $(use_with gd) \
+ $(use_with glob) \
+ $(use_with ldap) \
+ $(use_with lzma liblzma) \
+ $(use_with pcre) \
+ $(use_with zlib) \
+ --sysconfdir="${EPREFIX}/etc/sarg/"
+}
+
+src_install() {
+ default
+
+ dodoc documentation/*
+}