summaryrefslogtreecommitdiff
path: root/net-analyzer/rrdtool
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/Manifest1
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.7.2-r1.ebuild186
2 files changed, 187 insertions, 0 deletions
diff --git a/net-analyzer/rrdtool/Manifest b/net-analyzer/rrdtool/Manifest
index 6d3068aabbfe..f02f4e5cec56 100644
--- a/net-analyzer/rrdtool/Manifest
+++ b/net-analyzer/rrdtool/Manifest
@@ -14,5 +14,6 @@ DIST rrdtool-1.7.1.tar.gz 2881346 BLAKE2B e538c6ba3fb6726f0515ed655aa8d5e184f6d3
DIST rrdtool-1.7.2.tar.gz 2883737 BLAKE2B f3ff6cc4e325cdec42a6f9e67a1644f501c11edc47bc281df58c2e1d7be4c01767c35166f4301f68cf9c22dcd5c159bb51ee704a5e36776acdf166100122cebb SHA512 453230efc68aeb4a12842d20a9d246ba478a79c2f6bfd9693a91837c1c1136abe8af177be64fe29aa40bf84ccfce7f2f15296aefe095e89b8b62aef5a7623e29
EBUILD rrdtool-1.6.0-r1.ebuild 4256 BLAKE2B 96efab5cf4cbdd45e5f64bf41bae3de3260dfa2ad0699ae76b2c6f98c3e88369df5173fb465628dceabb4f8bc92216c8bb51955454a8bc25bfadbed8a63e5906 SHA512 08bba445ae1e6a2e91bcdf903647919e645930bf95786d41ae2663acd1b01eb06009a2ba582ac559ccee45686168fcca9c4592e11570e7f17a2ddeb08329523b
EBUILD rrdtool-1.7.1.ebuild 4251 BLAKE2B b422dd13981e28eaecc51396e6726eae4ce205ed2619a9a85035a2afba0729c8dcbb39956d08d5bf2422edeca2e876f05d6ba006d78f3980f10d3d332f3a83f6 SHA512 9c09607dd79f1bf9dd4936a45a1f58e7f2c5d13f0f7ea628ade5180612ed029a036168a05e7d60920e2c324a94d9b6fe283b7a27640c12430876d0ece41497db
+EBUILD rrdtool-1.7.2-r1.ebuild 4219 BLAKE2B a6d34b8875578e72fb8e9648faad2b309825940075e6a1b72af9d4df85d96acd0096ba27a35d8735e3ae23ccb509b61809a800dd1a21b34231aab46b50972d06 SHA512 349930ee617d987d165847c966c24804c0b97db2e17b123c1b22101cad8e7b6cee1cfd0b7507626d29ec302ec25d9528b8c30cca13cdaaeb1dbac8c1a3ac606d
EBUILD rrdtool-1.7.2.ebuild 4229 BLAKE2B 21c6ee4a85ffa9d56efab72b2c1dd5971fe003d4eccff17e18c560c6494da652e9744b4699751c377d396bb809d810038d0e250dc04179cdeabd6b5c170b32b6 SHA512 7fd0ef299215784dd335671bbd24ecf65e22b0ccbc9d63e0066679d1fc386bc92537d72b04d55e27b039331d6bf16070fdcef30110880266f2a6aaec4fa6a4c4
MISC metadata.xml 486 BLAKE2B d4e04c193a7b46a532791a0a448c7db4acaa4b4d4d775db70b6ab843ba32b616c91b516dbaca5b4e0a30649743553325a134291edb0ee17fe2ca049ed1e720ff SHA512 ddca3904aa3e0f1d2f543ae9329298a2dc69bbc0803c568d0871bb5ace21d2dee4d0b226e5eef0258fd59dd2cf046ee807afaa588e31db35e574f3d707894a23
diff --git a/net-analyzer/rrdtool/rrdtool-1.7.2-r1.ebuild b/net-analyzer/rrdtool/rrdtool-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..18ef0863e7e4
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.7.2-r1.ebuild
@@ -0,0 +1,186 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DISTUTILS_OPTIONAL=true
+DISTUTILS_SINGLE_IMPL=true
+GENTOO_DEPEND_ON_PERL=no
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit autotools perl-module distutils-r1 flag-o-matic multilib
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
+SRC_URI="https://oss.oetiker.ch/rrdtool/pub/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/8.0.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="dbi doc graph lua perl python rados rrdcgi ruby static-libs tcl tcpd"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="
+ >=dev-libs/glib-2.28.7:2[static-libs(+)?]
+ >=dev-libs/libxml2-2.7.8:2[static-libs(+)?]
+ dbi? ( dev-db/libdbi[static-libs(+)?] )
+ graph? (
+ >=media-libs/libpng-1.5.10:0=[static-libs(+)?]
+ >=x11-libs/cairo-1.10.2[svg,static-libs(+)?]
+ >=x11-libs/pango-1.28
+ )
+ lua? ( dev-lang/lua:* )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ rados? ( sys-cluster/ceph )
+ tcl? ( dev-lang/tcl:0= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+
+DEPEND="
+ ${CDEPEND}
+ sys-apps/groff
+ virtual/pkgconfig
+ virtual/awk
+"
+RDEPEND="
+ ${CDEPEND}
+"
+PDEPEND="
+ ruby? ( ~dev-ruby/rrdtool-bindings-${PV} )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.9-disable-rrd_graph-perl.patch
+ "${FILESDIR}"/${PN}-1.7.0-disable-rrd_graph-cgi.patch
+ "${FILESDIR}"/${PN}-1.7.1-configure.ac.patch
+)
+S=${WORKDIR}/${MY_P}
+
+python_compile() {
+ cd bindings/python || die
+ distutils-r1_python_compile
+}
+
+python_install() {
+ cd bindings/python || die
+ distutils-r1_python_install
+}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # At the next version bump, please see if you actually still need this
+ # before adding versions
+ if ! [ -f doc/rrdrados.pod ]; then
+ cp "${FILESDIR}"/${PN}-1.5.5-rrdrados.pod doc/rrdrados.pod
+ else
+ die "File already exists: doc/rrdrados.pod. Remove this code!"
+ fi
+
+ # bug 456810
+ # no time to sleep
+ sed -i \
+ -e 's|$LUA_CFLAGS|IGNORE_THIS_BAD_TEST|g' \
+ -e 's|^sleep 1$||g' \
+ -e '/^dnl.*png/s|^dnl||g' \
+ configure.ac || die
+
+ # Python bindings are built/installed manually
+ sed -i \
+ -e '/^all-local:/s| @COMP_PYTHON@||' \
+ bindings/Makefile.am || die
+
+ if ! use graph; then
+ sed -i \
+ -e '2s:rpn1::; 2s:rpn2::; 6s:create-with-source-4::;' \
+ -e '7s:xport1::; 7s:dcounter1::; 7s:vformatter1::' \
+ tests/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ export rd_cv_gcc_flag__Werror=no
+ export rd_cv_ms_async=ok
+
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
+
+ # to solve bug #260380
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
+
+ # Stub configure.ac
+ local myconf=()
+ if ! use tcpd; then
+ myconf+=( "--disable-libwrap" )
+ fi
+ if ! use dbi; then
+ myconf+=( "--disable-libdbi" )
+ fi
+ if ! use rados; then
+ myconf+=( "--disable-librados" )
+ fi
+
+ econf \
+ $(use_enable graph rrd_graph) \
+ $(use_enable lua lua-site-install) \
+ $(use_enable lua) \
+ $(use_enable perl perl-site-install) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable rrdcgi) \
+ $(use_enable static-libs static) \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
+ --with-perl-options=INSTALLDIRS=vendor \
+ --disable-ruby-site-install \
+ --disable-ruby \
+ ${myconf[@]}
+}
+
+src_compile() {
+ default
+
+ use python && distutils-r1_src_compile
+}
+
+src_test() {
+ export LC_ALL=C
+ default
+}
+
+src_install() {
+ default
+
+ if ! use doc ; then
+ rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
+ fi
+
+ if use !rrdcgi ; then
+ # uses rrdcgi, causes invalid shebang error in Prefix, useless
+ # without rrdcgi installed
+ rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
+ fi
+
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+
+ dodoc CHANGES CONTRIBUTORS NEWS THREADS TODO
+
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+
+ keepdir /var/lib/rrdcached/journal/
+ keepdir /var/lib/rrdcached/db/
+
+ newconfd "${FILESDIR}"/rrdcached.confd rrdcached
+ newinitd "${FILESDIR}"/rrdcached.init rrdcached
+
+ use python && distutils-r1_src_install
+}