summaryrefslogtreecommitdiff
path: root/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/python-gvm/python-gvm-21.11.0.ebuild')
-rw-r--r--net-analyzer/python-gvm/python-gvm-21.11.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
deleted file mode 100644
index 04a6a2b51111..000000000000
--- a/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1
-
-DESCRIPTION="Greenbone Vulnerability Management Python Library"
-HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/python-gvm/"
-SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-3+"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/defusedxml[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/paramiko[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # drop connection tests
- rm -r tests/connections || die
-}