summaryrefslogtreecommitdiff
path: root/net-analyzer/pbnj/pbnj-2.04-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pbnj/pbnj-2.04-r1.ebuild')
-rw-r--r--net-analyzer/pbnj/pbnj-2.04-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/pbnj/pbnj-2.04-r1.ebuild b/net-analyzer/pbnj/pbnj-2.04-r1.ebuild
new file mode 100644
index 000000000000..22d8615ff550
--- /dev/null
+++ b/net-analyzer/pbnj/pbnj-2.04-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit perl-module
+
+DESCRIPTION="A tool for running Nmap scans and diff'ing the results"
+HOMEPAGE="http://pbnj.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pbnj/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-perl/DBD-SQLite
+ dev-perl/DBI
+ dev-perl/File-HomeDir
+ dev-perl/File-Which
+ dev-perl/Nmap-Parser
+ dev-perl/Shell
+ dev-perl/Text-CSV_XS
+ dev-perl/XML-Twig
+ dev-perl/YAML
+"
+RDEPEND="
+ ${DEPEND}
+ net-analyzer/nmap
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.04-ipv4_sort.patch
+)
+
+src_prepare() {
+ default
+
+ mv t/04change.t{,his-test-fails} || die
+ mv t/05output.t{,his-test-fails} || die
+}