summaryrefslogtreecommitdiff
path: root/net-analyzer/nmap/nmap-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-9999.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index 8617f57210bf..f18840ef8839 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -30,10 +30,10 @@ fi
# https://github.com/nmap/nmap/issues/2199
LICENSE="NPSL-0.95"
SLOT="0"
-IUSE="ipv6 libssh2 ncat ndiff nping nls +nse ssl symlink +system-lua zenmap"
+IUSE="ipv6 libssh2 ncat ndiff nping nls +nse ssl symlink zenmap"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
- system-lua? ( nse ${LUA_REQUIRED_USE} )
+ nse? ( ${LUA_REQUIRED_USE} )
symlink? ( ncat )
"
@@ -47,7 +47,10 @@ RDEPEND="
sys-libs/zlib
)
nls? ( virtual/libintl )
- nse? ( sys-libs/zlib )
+ nse? (
+ ${LUA_DEPS}
+ sys-libs/zlib
+ )
ssl? ( dev-libs/openssl:= )
symlink? (
ncat? (
@@ -55,7 +58,6 @@ RDEPEND="
!net-analyzer/openbsd-netcat
)
)
- system-lua? ( ${LUA_DEPS} )
zenmap? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
@@ -64,6 +66,7 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}"
+# Python is always needed at build time for some scripts
BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
@@ -90,7 +93,7 @@ PATCHES=(
pkg_setup() {
python-single-r1_pkg_setup
- use system-lua && lua-single_pkg_setup
+ use nse && lua-single_pkg_setup
}
src_prepare() {
@@ -134,10 +137,10 @@ src_configure() {
$(use_with ncat)
$(use_with ndiff)
$(use_with nping)
+ $(use_with nse liblua)
$(use_with ssl openssl)
$(use_with zenmap)
$(usex libssh2 --with-zlib)
- $(usex nse --with-liblua=$(usex system-lua yes included '' '') --without-liblua)
$(usex nse --with-zlib)
--cache-file="${S}"/config.cache
# The bundled libdnet is incompatible with the version available in the