summaryrefslogtreecommitdiff
path: root/net-analyzer/nfdump/nfdump-1.6.24.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nfdump/nfdump-1.6.24.ebuild')
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.24.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-analyzer/nfdump/nfdump-1.6.24.ebuild b/net-analyzer/nfdump/nfdump-1.6.24.ebuild
index abe553c93b29..d4302f132f6c 100644
--- a/net-analyzer/nfdump/nfdump-1.6.24.ebuild
+++ b/net-analyzer/nfdump/nfdump-1.6.24.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="A set of tools to collect and process netflow data"
HOMEPAGE="https://github.com/phaag/nfdump"
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="debug doc jnat ftconv nfpcapd nfprofile nftrack nsel readpcap sflow"
REQUIRED_USE="?? ( jnat nsel )"
@@ -19,6 +19,7 @@ REQUIRED_USE="?? ( jnat nsel )"
RDEPEND="
app-arch/bzip2
sys-libs/zlib
+ elibc_musl? ( sys-libs/fts-standalone )
ftconv? ( net-analyzer/flow-tools )
nfpcapd? ( net-libs/libpcap )
nfprofile? ( net-analyzer/rrdtool )
@@ -54,6 +55,9 @@ src_prepare() {
src_configure() {
tc-export CC
+ # bug #853763
+ use elibc_musl && append-libs "-lfts"
+
# --without-ftconf is not handled well, bug #322201
econf \
$(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \