summaryrefslogtreecommitdiff
path: root/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild')
-rw-r--r--net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild b/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
index ba36c687bf3f..3178d81adff6 100644
--- a/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
+++ b/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+inherit git-r3 flag-o-matic toolchain-funcs
DESCRIPTION="Analysis tools for Multipath Transmission Control Protocol (MPTCP)"
HOMEPAGE="https://github.com/nasa/multipath-tcp-tools"
@@ -31,6 +31,9 @@ src_prepare() {
}
src_compile() {
+ # bug #861179
+ append-flags -fno-strict-aliasing
+
emake \
CXX="$(tc-getCXX)" \
CXXFLAGS="${CXXFLAGS}"