summaryrefslogtreecommitdiff
path: root/net-analyzer/linkchecker/linkchecker-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/linkchecker/linkchecker-9999.ebuild')
-rw-r--r--net-analyzer/linkchecker/linkchecker-9999.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/net-analyzer/linkchecker/linkchecker-9999.ebuild b/net-analyzer/linkchecker/linkchecker-9999.ebuild
index 1d23dd82d824..9bcf1112b5ea 100644
--- a/net-analyzer/linkchecker/linkchecker-9999.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="sqlite?"
inherit bash-completion-r1 distutils-r1 optfeature
@@ -22,7 +22,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
IUSE="sqlite"
-# requires py2 only libs
+# requires libs not present in portage yet
RESTRICT="test"
RDEPEND="
@@ -30,23 +30,24 @@ RDEPEND="
dev-python/dnspython[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
"
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-9.3-bash-completion.patch"
- )
+PATCHES=(
+ "${FILESDIR}/${PN}-9.3-bash-completion.patch"
+)
+
+DOCS=(
+ doc/changelog.txt
+ doc/upgrading.txt
+)
+python_prepare_all() {
distutils-r1_python_prepare_all
}
python_install_all() {
- local DOCS=(
- doc/changelog.txt
- doc/upgrading.txt
- )
distutils-r1_python_install_all
-
newbashcomp config/linkchecker-completion ${PN}
}