summaryrefslogtreecommitdiff
path: root/net-analyzer/ipv6toolkit
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ipv6toolkit')
-rw-r--r--net-analyzer/ipv6toolkit/Manifest3
-rw-r--r--net-analyzer/ipv6toolkit/ipv6toolkit-2.1_p20190919.ebuild45
-rw-r--r--net-analyzer/ipv6toolkit/ipv6toolkit-99999999.ebuild43
3 files changed, 91 insertions, 0 deletions
diff --git a/net-analyzer/ipv6toolkit/Manifest b/net-analyzer/ipv6toolkit/Manifest
index ba23fc688cb5..f66a4be17ed3 100644
--- a/net-analyzer/ipv6toolkit/Manifest
+++ b/net-analyzer/ipv6toolkit/Manifest
@@ -1,3 +1,6 @@
DIST ipv6toolkit-2.0_p20160422.tar.gz 796716 BLAKE2B 468375afbf385ac9b571708be1baff0b0c56a0895bb73f3711522120b0e5fdfded3d73fea2a7d48b38f1e6387e0d63674c08eb503281f6eb635ea131ae67ec47 SHA512 532d6b76159fca03bdcebe341540a4071d2381dd3046469d0dfa5e8eecda5ffb4182d40658ef14c67bd11b781773bff1192e96d0ac4210c5ca095c6475d6c26d
+DIST ipv6toolkit-2.1_p20190919.tar.gz 979235 BLAKE2B 1b652b00874b9a71a5e5b86643d9c71fc02917af93d9730e7e4be7e5203d07dfef5bc7d1bb0453a6bf9dece69f7f4256912f0902132dd21530ae8ea9e94b8b4f SHA512 78e7565f4827d21573ced06002311a4f3736df71846085b3e8e47e0d6aebeaa4e60881c148c3c65ee010ffcfb2bf3ad56bb2625203aff5b0fdf40fbb7f37ecb9
EBUILD ipv6toolkit-2.0_p20160422.ebuild 1245 BLAKE2B e108d57bf264bc9b0d1f42e83b638354520832267bfa6c700dd7630e163e5da3aeebe332be7786c21cb86dcbd216e579ed669d402373135440d98ea0fdabe014 SHA512 f3c18c571a6c341697135c3cb1b355bed43bc79a61bdf048c112819e312658b260b8afca432e046fa391a16af8e97d36644daf77dd11d236d3b70ae263d88ea7
+EBUILD ipv6toolkit-2.1_p20190919.ebuild 1158 BLAKE2B be8f899af0570e84204eb8f72cc4199f9d486b9ffe10d1a98496463577fe6d62b69add5e4e07fa93a5193f396cb7f772d2ce04f6759faebdae1fe6f9625127ae SHA512 29b9e9fbc19dd1f9400bf5fa4e350c5859ca1b650410f8f57a92898d3d933a67cec8af2e1d25fea1e44b09d091cc091e8705cf1ea91b26ba9d8c00ef88c58cfd
+EBUILD ipv6toolkit-99999999.ebuild 1029 BLAKE2B da79779c2bb84b817aa197e86931e8fdc8a14597916a867bd01cc211b770425e485bfb19f28345a85a62b60e8bea8f5c2065c26b5e89699d67e306f5746d2a3c SHA512 376b1b2b881e0285f084b8edad8f4aefc83683d3f4c947e3ca4ada0518bc9291ed8f09bc3bbd275e27f32532857ef33ae2006277c6341adf800a5471274d39c1
MISC metadata.xml 527 BLAKE2B e275ef7193981f8415d0aa0973743deb8b4b0302fb093a26254dd0e681e072e175466869335c909c2f39ecc241f2de1e1a8135b0f6f59f17a566fcd5d9065e51 SHA512 acec773e132e352f4f81af6840f3370da00f48e5e13f39a2fccc441e5d119c5fac4319b24745eef1b4fb0921e8ace7456f7230432fd86978bb27cc54b7de3ec4
diff --git a/net-analyzer/ipv6toolkit/ipv6toolkit-2.1_p20190919.ebuild b/net-analyzer/ipv6toolkit/ipv6toolkit-2.1_p20190919.ebuild
new file mode 100644
index 000000000000..6a4df21782ca
--- /dev/null
+++ b/net-analyzer/ipv6toolkit/ipv6toolkit-2.1_p20190919.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Set of IPv6 security/trouble-shooting tools to send arbitrary IPv6-based packets"
+HOMEPAGE="https://www.si6networks.com/tools/ipv6toolkit/"
+SNAPSHOT="20de5f297f73b6a8115d1eac52adfe0b6df5b3ed"
+SRC_URI="https://github.com/fgont/ipv6toolkit/archive/${SNAPSHOT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/"${PN}"-"${SNAPSHOT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-libs/libpcap[ipv6(+)]
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/hwids
+"
+
+HWIDS_OUI_PATH=/usr/share/misc/oui.txt
+
+src_prepare() {
+ default
+ sed -i "s#/usr/share/ipv6toolkit/oui.txt#${HWIDS_OUI_PATH}#" \
+ manuals/ipv6toolkit.conf.5
+}
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PREFIX=/usr
+}
+
+src_install() {
+ dodir /etc
+ emake install DESTDIR="${ED}" PREFIX=/usr
+ #remove the included oui file
+ rm -f "${D}"/usr/share/ipv6toolkit/oui.txt
+ #fix the conf file to use the one from sys-apps/hwids
+ sed -i "s#/usr/share/ipv6toolkit/oui.txt#${HWIDS_OUI_PATH}#" \
+ "${ED}"/etc/ipv6toolkit.conf
+ dodoc CHANGES.TXT README.TXT
+}
diff --git a/net-analyzer/ipv6toolkit/ipv6toolkit-99999999.ebuild b/net-analyzer/ipv6toolkit/ipv6toolkit-99999999.ebuild
new file mode 100644
index 000000000000..8a862e677183
--- /dev/null
+++ b/net-analyzer/ipv6toolkit/ipv6toolkit-99999999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Set of IPv6 security/trouble-shooting tools to send arbitrary IPv6-based packets"
+HOMEPAGE="https://www.si6networks.com/tools/ipv6toolkit/"
+EGIT_REPO_URI="https://github.com/fgont/ipv6toolkit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ net-libs/libpcap[ipv6(+)]
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/hwids
+"
+
+HWIDS_OUI_PATH=/usr/share/misc/oui.txt
+
+src_prepare() {
+ default
+ sed -i "s#/usr/share/ipv6toolkit/oui.txt#${HWIDS_OUI_PATH}#" \
+ manuals/ipv6toolkit.conf.5
+}
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" PREFIX=/usr
+}
+
+src_install() {
+ dodir /etc
+ emake install DESTDIR="${ED}" PREFIX=/usr
+ #remove the included oui file
+ rm -f "${D}"/usr/share/ipv6toolkit/oui.txt
+ #fix the conf file to use the one from sys-apps/hwids
+ sed -i "s#/usr/share/ipv6toolkit/oui.txt#${HWIDS_OUI_PATH}#" \
+ "${ED}"/etc/ipv6toolkit.conf
+ dodoc CHANGES.TXT README.TXT
+}