summaryrefslogtreecommitdiff
path: root/net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild')
-rw-r--r--net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild b/net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild
new file mode 100644
index 000000000000..ade8bba29931
--- /dev/null
+++ b/net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Set metrics of all IPv4 routes attached to a given network interface at once"
+HOMEPAGE="http://0pointer.de/lennart/projects/ifmetric/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+DEPEND="sys-kernel/linux-headers"
+
+DOCS=(
+ README
+ doc/README.html
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ul.patch
+ "${FILESDIR}"/${P}-replybuf.patch
+)
+
+src_configure() {
+ # man page and HTML are already generated
+ econf \
+ --disable-xmltoman \
+ --disable-lynx
+}