summaryrefslogtreecommitdiff
path: root/net-analyzer/hydra/files/hydra-9.4-implicit-func-decl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hydra/files/hydra-9.4-implicit-func-decl.patch')
-rw-r--r--net-analyzer/hydra/files/hydra-9.4-implicit-func-decl.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/net-analyzer/hydra/files/hydra-9.4-implicit-func-decl.patch b/net-analyzer/hydra/files/hydra-9.4-implicit-func-decl.patch
deleted file mode 100644
index bf4dd61e33ce..000000000000
--- a/net-analyzer/hydra/files/hydra-9.4-implicit-func-decl.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/vanhauser-thc/thc-hydra/pull/786
-
-From 613bd02264dcc989eeeb77b83603d4c2f48f0bbc Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Fri, 9 Sep 2022 04:32:05 +0100
-Subject: [PATCH] Makefile.am: add -D_GNU_SOURCE for strcasestr
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-strcasestr is not a standard function and per
-the man page, needs -D_GNU_SOURCE to be visible.
-
-Fixes a build error:
-```
-hydra-rtsp.c:20:7: error: implicit declaration of function ‘strcasestr’; did you mean ‘strcasecmp’? [-Werror=implicit-function-declaration]
- 20 | if (strcasestr(s, "401 Unauthorized") != NULL) {
- | ^~~~~~~~~~
- | strcasecmp
-```
-
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -5,6 +5,7 @@ WARN_CLANG=-Wformat-nonliteral -Wstrncat-size -Wformat-security -Wsign-conversio
- WARN_GCC=-Wformat=2 -Wformat-overflow=2 -Wformat-nonliteral -Wformat-truncation=2 -Wnull-dereference -Wstrict-overflow=2 -Wstringop-overflow=4 -Walloca-larger-than=4096 -Wtype-limits -Wconversion -Wtrampolines -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fno-common -Wcast-align
- CFLAGS ?= -g
- OPTS=-I. -O3 $(CFLAGS) -fcommon
-+CPPFLAGS += -D_GNU_SOURCE
- # -Wall -g -pedantic
- LIBS=-lm
- DESTDIR ?=
-