summaryrefslogtreecommitdiff
path: root/net-analyzer/gr-fosphor
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/gr-fosphor')
-rw-r--r--net-analyzer/gr-fosphor/Manifest6
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-0.0_p20191202.ebuild64
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131.ebuild64
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild16
4 files changed, 141 insertions, 9 deletions
diff --git a/net-analyzer/gr-fosphor/Manifest b/net-analyzer/gr-fosphor/Manifest
index 9d7bec1013b1..e52f36f808e8 100644
--- a/net-analyzer/gr-fosphor/Manifest
+++ b/net-analyzer/gr-fosphor/Manifest
@@ -1,2 +1,6 @@
-EBUILD gr-fosphor-9999.ebuild 1324 BLAKE2B fb6e43ec50f469d9fe71b1f2ab3e275c94e3f552f9a034ac86fe8253c09ecca22efb54390dabcd2570ad9484132d482d8805a836886fe56dac45db5963913421 SHA512 eeacf7ccb39e22fdb31e3b6035b57d68b151455ce4219ffde6dcbfc11a7280fa6253ea0fde990395212a38dc09bfd8e39a2a3b690168cf3d76ddaf4c7107dee6
+DIST gr-fosphor-0.0_p20191202.tar.gz 254103 BLAKE2B 460b4ff2ff9f4a6faa70c541dd8ce936ba8419a89cca7715913b6f93f07a151c467a5737860a362198d609dfe0e4bfc4a476278bfc720d89c1876ff56addf226 SHA512 6bc26be4aa3116af33a214046c76e5a7623e049e27e86d866892de611ffd4bfa4bd841b66535fc40320fa7c7a46d19af2d391ee594f9a7ed997355cd2ade6fa1
+DIST gr-fosphor-0.0_p20200131.tar.gz 244685 BLAKE2B db01b9df87f377db2adaaca3d1542f99eaca9f73303c71ea9add1845307704817c8930736d44462191476b4cb935a18401b7012a1ea6465bdb5cf3624c182f2c SHA512 7bf2758f98ae7d088256060878fbf33966880ddbb7fb132da00f9c2530d84b91a6385eabbf61ff40d3002d3a42eadf5e2d78b8c797bc93501cafaf8a7bdde7ae
+EBUILD gr-fosphor-0.0_p20191202.ebuild 1379 BLAKE2B e24557d185a06d139ba915dfadb23eb99d434f88f09bb006fcbb7cfc0d565905bc095cd83e630d4b80b97c1fc25b906b5eefa5b8ecba00f5b7b950bda869c53a SHA512 c764a9ed59af2a4b929add701485cf89a5ed0563f0caddf29dc71fb23cc8e0fe00c92a834ad4acbdbd95fd335648d4d0c3f71f4bcccc84d455cd5086decfb873
+EBUILD gr-fosphor-0.0_p20200131.ebuild 1348 BLAKE2B c8c977e0b34e33e3e456c4a18b8149903b9391741500344ad904aa06e7c662cd28abed1330228ddd856ab40fac893650b38c3c5f0fa1c00b3830891a073f5ace SHA512 6cee886a5f0eab8b8be388664fd03bcd1c4746281d4dc86f15666eb7651e8412fed4fc5f0ff2f31cb00f7e8c8a5657f0ff32a082777c08f960c63beef6731c02
+EBUILD gr-fosphor-9999.ebuild 1348 BLAKE2B c8c977e0b34e33e3e456c4a18b8149903b9391741500344ad904aa06e7c662cd28abed1330228ddd856ab40fac893650b38c3c5f0fa1c00b3830891a073f5ace SHA512 6cee886a5f0eab8b8be388664fd03bcd1c4746281d4dc86f15666eb7651e8412fed4fc5f0ff2f31cb00f7e8c8a5657f0ff32a082777c08f960c63beef6731c02
MISC metadata.xml 308 BLAKE2B 365c82d2c544f94f613bee62f13ab91dcbefd1652fccfec5222a616443714400c686eb5d77c892b44ab0c1badd1877b4bd0dcb9040c98720c13934d567482857 SHA512 cca3e1ffd2ee31e64dbea0f66093f3295b9e1ce2161b9b71dbd1d518a6a0ff83843c684c1c958bffb80b4f4fda9d5a272be8d6ab2ecf6f0fe57202a65a218df9
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20191202.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20191202.ebuild
new file mode 100644
index 000000000000..78c0f817bcf6
--- /dev/null
+++ b/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20191202.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
+HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
+else
+ COMMIT="fa6761afbf8c2658782e0c7fc5d51063679b7ae4"
+ SRC_URI="https://github.com/osmocom/gr-fosphor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="glfw qt5 wxwidgets"
+
+RDEPEND="qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )
+ =net-wireless/gnuradio-3.7*:0=[qt5,wxwidgets?,${PYTHON_SINGLE_USEDEP}]
+ media-libs/freetype
+ dev-libs/boost:=
+ glfw? ( >=media-libs/glfw-3 )
+ virtual/opencl
+ virtual/opengl
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0
+ dev-util/cppunit
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ default
+}
+
+src_configure() {
+ # tries to run OpenCL test program, but failing doesn't hurt
+ addpredict /dev/dri
+
+ local mycmakeargs=(
+ -DENABLE_DEFAULT=OFF
+ -DENABLE_GLFW="$(usex glfw)"
+ -DENABLE_QT="$(usex qt5)"
+ -DENABLE_WX="$(usex wxwidgets)"
+ -DENABLE_PYTHON=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131.ebuild
new file mode 100644
index 000000000000..73f6863f9df9
--- /dev/null
+++ b/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
+HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
+else
+ COMMIT="defdd4aca6cd157ccc3b10ea16b5b4f552f34b96"
+ SRC_URI="https://github.com/osmocom/gr-fosphor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="glfw qt5"
+
+RDEPEND="qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )
+ dev-libs/boost:=
+ dev-libs/log4cpp
+ media-libs/freetype
+ =net-wireless/gnuradio-3.8*:0=[qt5,${PYTHON_SINGLE_USEDEP}]
+ glfw? ( >=media-libs/glfw-3 )
+ virtual/opencl
+ virtual/opengl
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0
+ dev-util/cppunit
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ default
+}
+
+src_configure() {
+ # tries to run OpenCL test program, but failing doesn't hurt
+ addpredict /dev/dri
+
+ local mycmakeargs=(
+ -DENABLE_DEFAULT=OFF
+ -DENABLE_GLFW="$(usex glfw)"
+ -DENABLE_QT="$(usex qt5)"
+ -DENABLE_PYTHON=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
index 0eceaac74e02..73f6863f9df9 100644
--- a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake-utils python-single-r1
@@ -11,11 +11,11 @@ HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- #EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
- EGIT_BRANCH="gr3.7-qt5"
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ COMMIT="defdd4aca6cd157ccc3b10ea16b5b4f552f34b96"
+ SRC_URI="https://github.com/osmocom/gr-fosphor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~x86"
fi
@@ -23,7 +23,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="glfw qt5 wxwidgets"
+IUSE="glfw qt5"
RDEPEND="qt5? (
dev-qt/qtcore:5
@@ -31,9 +31,10 @@ RDEPEND="qt5? (
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
- >=net-wireless/gnuradio-3.7_rc:0=[qt5,wxwidgets?,${PYTHON_SINGLE_USEDEP}]
- media-libs/freetype
dev-libs/boost:=
+ dev-libs/log4cpp
+ media-libs/freetype
+ =net-wireless/gnuradio-3.8*:0=[qt5,${PYTHON_SINGLE_USEDEP}]
glfw? ( >=media-libs/glfw-3 )
virtual/opencl
virtual/opengl
@@ -57,7 +58,6 @@ src_configure() {
-DENABLE_DEFAULT=OFF
-DENABLE_GLFW="$(usex glfw)"
-DENABLE_QT="$(usex qt5)"
- -DENABLE_WX="$(usex wxwidgets)"
-DENABLE_PYTHON=ON
)
cmake-utils_src_configure