summaryrefslogtreecommitdiff
path: root/net-analyzer/fragroute/fragroute-1.2.6-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/fragroute/fragroute-1.2.6-r3.ebuild')
-rw-r--r--net-analyzer/fragroute/fragroute-1.2.6-r3.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/net-analyzer/fragroute/fragroute-1.2.6-r3.ebuild b/net-analyzer/fragroute/fragroute-1.2.6-r3.ebuild
deleted file mode 100644
index 60b3c08bfca8..000000000000
--- a/net-analyzer/fragroute/fragroute-1.2.6-r3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${P}-ipv6"
-
-inherit autotools
-
-DESCRIPTION="Testing of network intrusion detection systems, firewalls and TCP/IP stacks"
-HOMEPAGE="https://github.com/stsi/fragroute-ipv6"
-SRC_URI="https://fragroute-ipv6.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-RDEPEND="
- >=dev-libs/libdnet-1.12[ipv6]
- dev-libs/libevent:=
- net-libs/libpcap
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- virtual/awk
-"
-DOCS=( INSTALL README TODO )
-PATCHES=(
- "${FILESDIR}"/${P}-libdir.patch
- "${FILESDIR}"/${P}-pcap_open.patch
-)
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
-
- # Remove broken and old files, autotools will regen needed files
- rm *.m4 acconfig.h missing Makefile.in || die
-
- # Add missing includes
- sed -i -e "/#define IPUTIL_H/a#include <stdio.h>\n#include <stdint.h>" iputil.h || die
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- DNETINC='' \
- DNETLIB=-ldnet \
- EVENTINC='' \
- EVENTLIB=-levent \
- PCAPINC='' \
- PCAPLIB=-lpcap
-}